Hello all new user

i just got the Veroplus
And it’s a little smart box.
nicely made looks good.
only point is the SD-slot is springloaded and not locking. (it pops out every time i push it inwards)
is this normal?

Make sure the SD card is being inserted so the logo faces down and pins are upwards.

It depends a bit how the board lines up with the case. You need to use your fingernail to push it in.

tested two different micro SD’s both came out.
the notch of the SD and the nail hole are aligned.
(otherway around it dont fit)

i would suspect:
push in lock
push twiche unlock pops out.
or use nail to pull out.

damn, the nail did it. i needed it to push deeper then the case! i feel dumb.

anything else i need to be aware of wile booting up the first time?
it wil replacing a Cuboxi so i have HDMI, optical wire, utp-connection internet lined up.

Just go for it. If you know Kodi you will be fine and there’s help in here. Search for file sharing, audio setup. Ask if you get stuck.

1 Like

ok i installed the box (on thing was not clear. => the IR reciever do i put that in the right or left socket? or in the Smart TV? there are no writing on the case or icons so its foggy.)
i have a IR in the TV from the old kodibox. (i suppose or it’s from the TV it’s self geesh long time i installed that memory is blurry about that.)
any way wired mac and ip adres recerved, named in router, optical spdiff HMDI (max 1.4 of TV) original power adapter. remote dongle in usb1
first run through settings. quite easy.
connected Yatse mobile. (easier for typing)

Its running datascrapers now. So i have to wait till it’s idle.
one tiny thing i lost a lot of time on.
“Samba server”
never knew i needed to instal that first. (maybe it’s too long ago i did a full install but it costed me alote of time before i understood what’s missing. (yep not a # https warrior)
tried different approaches to get first acces to my nass. even screenshotted my old install.
then after i was convinced i wasn’t wrong in entering :sweat_smile: i looked on the big web.
there it was “YOU NEED TO INSTALL SAMBA FIRST!” :unamused:
So from there it was easy enough.
fine tuning and skin tuning will be later.
same as add-ons i did some like missing movies and weather and music art.

So two remarks:
samba server, why is it not “stated” by SMB header that you need it installed first before smb works? could be a clue pointer :wink:
The papermanual in the box, the picture of the vero4k and interface sockets, just write some text and point at it what it is.
like audio, and optical spdiff (is for me officious i used it already but others would not see the clue i think.
also on the official website no “what’s this hole for” information.
it’s no biggy but it would speed up the installing and makes mistakes less.


Hi, thanks for the feedback. The paper “manual”, is what it is and I doubt it would be cost affiant to print a new version. But that doesn’t refrain us from doing a " ‘My First Install’-questions" in the wiki, will look into that when i get a few moments to spare.

When I comes to samba, are you saying that inorder to access you NAS samba shares you had to install Samba server on your Vero4k(+)?

Let me state that i am not a frequent installer of osmc/kodi related hardware.
I have lots of self made “how to do this” documents. As kind of reminders when i need to reinstal something because something goes wrong.
And the first entering of a ip adres of a nass is every time a few trail and erors before i find the right way. From there it’s more easy.

I found a windows (win os) related help file. So i thought hmmm, could that be my problem of not accessing my nass?
First attempt
Add networkadres
(nass has user and pasword acces.)
Smb:// (that’s what shows in the list of networkfolders.)
All where wrong or acces denied.
So i just tried and installed that samba server you can find in the osmc wheel.
And from that moment i could instal and got acces.
The //numbers/video/ got blue on this site so i suppose that’s the right way… :wink:
I even tried “https://numbers/video/
Thus it’s more that it worked after i installed the samba server.
Site i used to learn the trick its in dutch.

So it could be a coincidence. :slightly_smiling_face:

Still running scrapers.
Are you try to tell me that i don’t need samba server running on the vero4k?

Samba is a networking component for Linux OS’s that provides connectivity to SMB networking (The standard network type that Windows uses). Kodi has support built in to access SMB networking without any other component needing to be installed. The Samba server install is to allow your device to share files it has access to with other computers using SMB. So no, to just access files on a NAS device there is no need to be running Samba server on a Vero.

As for manually typing in a network address with credentials it would be…


at which point current versions of Kodi will store your credentials and strip them from the source path. Once you have done once and Kodi stores the credentials then you no longer have to include them for any subsequent sources you add (assuming they all are pointing to the same device and use the same credentials). This being said the better way is to use the “add network location” option where you put in this information all into its own separate spaces and that produces a new entry that you would choose when browsing for your sources where you don’t have to manually type anything in.

As for the remote dongle it is not IR, it is RF and you can plug it into either of the USB ports on the Vero.

I ment that 3.5mm plug and sensor on a Wire.

Ok, i can turn samba server off and of uninstall then?

Ok i will in the future.
Strange thing is
The fill in page has a adres fill in and two lines for username and password.
So i assummed

Pointing towards a adres should nok on the door of the nass.

Then it should be ok right?
If i shutdown the sambaserver i don’t have connection issues due the way i activated smb//:ipadres?

(I will try to shutdown the samba server tomorrow.)

That is just an option for someone who is using an IR remote instead of the one the Vero comes with or CEC and also has their Vero situated such that the IR sensor on the front of the Vero is not line of sight. If this situation does not apply, there is no reason or benefit to plugging it in.

I was talking about if you were to just video>files>add videos which just has the single line for input.

Regardless of which way you input a source location in Kodi the end result is the same. It is just adding a network location (ie the NAS/PC itself and not an individual share) just makes it easier as it allows you to then just video>files>add videos>browse>(source machine)>share>OK>OK and then that source is done without any additional typing of paths. You will need separate sources for movies, TV, and music so this way helps speed up that setup.

If you want. I don’t think it would really hurt anything to leave running.

The two are not connected in any way. The method you used is entirely contained inside of Kodi and it has zero interactions with that OS level function.

1 Like

The manual will indeed be updated in the near future to show a diagram.

1 Like

Great :slightly_smiling_face:
I don’t want to push a dent in the boot :sweat_smile: but what would it cost to create printed or relief icons near the two round jackplug holes?
And maybe the toslink and micro SD. To make clear what it is for?
The HDMI , power and internetsocket are recognisable enough for every one.

The total appearance of the Vero4kplus is luxurious and sturdy. Look great.
I was pleasant surpiced to find a sticky holder in the package to glue behind the tv.
I have a oldfasion cabinet with VHS-video recorder space so there lies al my connectiongear so i dont need it. Good luxary packagebox all gear neatly tucked in.
Good first impression. Wife happy with the neat look.

Let i speak first it’s no criticism more observation from a guy who repairs officeappliance and knows about heating up electronics by bad ventilation due dust.:slightly_smiling_face:
One thing i noticed too is the ventilation grills are at the bottom, nicely out of sight, but the rubber spacers are that low (1mm?) that when i place the vero4k flat on a desk there is nearly no airvent space is to see.
My cuboxi is fairly “hot” when it’s on, hotter then the vero4kplus i just measured with a ir-gun😁
Woodendesk 18,5 degrees celcius and idle vero4k 21,3 degrees.

If the vero is running on 100% is that space sufficient for airflow and cooling?
Made some photo’s to explain.
Present view

Then the bracket of the box underneed in the slots.

That is the space you get hanging on the back of the TV.
Now my additional spacers, still less then the thicknes of the bracket.

At last the spacers which layed underneath. Around 3mm thick.


I think you get triple the amout of airflowspace for flat placement and still no Interfearance when you place it on the bracket.

I suspect most customers would hide the box behind the tv or wallmount so it’s not something what is important. But i found it worth to speak out.
Do with it as you like. :blush:

I am in quarantine so lots of time to play with my new toy. :grin:

The Vero normally doesn’t run at 100% (I assume you refer to CPU load).
I have my Vero in a very similar space as you together with my router and firewall. The Vero runs at a stable 58 degrees Celsius CPU temperature (winter time) and 62 degrees Celsius (summer time).

Hi, ok so that 1mm space is suffient enough?
100% run i ment playing a dts movie for 2 hours and more in FHD or 4K.
I measured the outsidecase. System hardware menu shows cpu 47c idle.
That old cuboxi was suffering from getting too much load and was twice the heat on surface. (didn’t check cpu lately) Often buffering issue’s and crashes when fastforwarding. i recon this vero4k has a fieldday on my 1080p setup. “Old” FHD smarttv

If anyone is interested i can re-connect my old cubox and let it run for an hour to check.:grin:

4k movies (h.265) are hardware decoded means the CPU is not used for that and the Vero stays cool during that times.

1 Like