Help getting remote working on Pi2

EDIT: OH, so embarrassing… this is why we don’t let the software guy hook up the hardware. I swapped the power and ground connections. But I’ll leave this here, as it may be useful, and I should be able to provide information about this remote, once I get it working.

I have

  • Current OSMC Krypton
  • TSOP4838 connected to pins 1, 6, 12 (GPIO 18)
  • Zenith ZB310 remote (yes, the batteries are in, and it works)

ls -l /dev/lir* says:

crw-rw---- 1 root video 244, 0 Feb 21 12:53 /dev/lirc0

dmesg includes:

[    4.361247] lirc_dev: IR Remote Control driver registered, major 244 
[    4.419405] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[    4.433487] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
[    4.438122] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    4.692339] input: Logitech Gamepad F310 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/input/input0
[    4.692709] usbcore: registered new interface driver xpad
[    4.933151] FAT-fs (mmcblk0p6): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    5.378641] lirc_rpi: auto-detected active low receiver on GPIO pin 18
[    5.378970] lirc_rpi lirc_rpi: lirc_dev: driver lirc_rpi registered at minor = 0
[    5.378984] lirc_rpi: driver registered!
[    5.605941] input: lircd as /devices/virtual/input/input1

lsmod includes:

bcm2835_gpiomem         4026  0 
bcm2835_thermal         2541  0 
bcm2835_wdt             4081  0 
lirc_rpi                9342  3 
lirc_dev               11576  1 lirc_rpi
rc_core                25745  1 lirc_dev

sudo cat /sys/kernel/debug/gpio says:

GPIOs 0-53, platform/3f200000.gpio, pinctrl-bcm2835:
 gpio-35  (                    |?                   ) in  hi    
 gpio-47  (                    |?                   ) out lo 

My config.txt includes:

# Infrared Remote Control`


To ensure nothing else is competing for access to this, I use:

sudo kill $(pidof lircd)
sudo systemctl stop lircd_helper@lirc0

Then neither of these produce any results:

mode2 -d /dev/lirc0

irrecord -d /dev/lirc0 ~/newlircd.conf

I tried search for answers what to do next, but I haven’t found anyone where they aren’t getting anything at all back…

Glad you worked it out.

Kudos for leaving your query as a potential solution for others and updating your post.

Here is the newlircd.conf file that was generated by irrecord, with comments added. For me, it works great!

# Please make this file available to others
# by sending it to <>
# this config file was automatically generated
# using lirc-0.9.0(default) on Tue Feb 21 14:48:28 2017
# contributed by wanyodiva
# brand: Zenith                      /home/osmc/newlircd.conf
# model no. of remote control: ZB310 
# devices being controlled by this remote:
#       Raspberry Pi 2, with attached TSOP4838 on GPIO 18, running OSMC
#       The remote is set to interact with DVD/VCR as Media Center PC
#       by setup code 1100.  This file does not include any keypresses
#       for TV or for CBL/SAT.  Buttons that I did not configure
#       are Setup, Input, TV, and CBL/SAT.  To get Record to work
#       you need to press it twice, as it says in the manual.

begin remote

  name  /home/osmc/newlircd.conf
  bits           13
  eps            30
  aeps          100

  header       2690   860
  one           470   421
  zero          470   421
  pre_data_bits   24
  pre_data       0x1BFF83
  gap          105888
  min_repeat      1
#  suppress_repeat 1
#  uncomment to suppress unwanted repeats
  toggle_bit_mask 0x8000
  rc6_mask    0x100000000

      begin codes
          KEY_1                    0x1BFE
          KEY_2                    0x1BFD
          KEY_3                    0x1BFC
          KEY_4                    0x1BFB
          KEY_5                    0x1BFA
          KEY_6                    0x1BF9
          KEY_7                    0x1BF8
          KEY_8                    0x1BF7
          KEY_9                    0x1BF6
          KEY_0                    0x1BFF
          KEY_DOT                  0x1BDA
          KEY_ENTER                0x1BF4
          KEY_REWIND               0x1BEA
          KEY_PLAY                 0x1BE9
          KEY_FASTFORWARD          0x1BEB
          KEY_STOP                 0x1BE6
          KEY_PAUSE                0x1BE7
          KEY_POWER                0x1BF3
          KEY_MENU                 0x1BDB
          KEY_SUBTITLE             0x1BB2
          KEY_INFO                 0x1BF0
          KEY_TITLE                0x1BD9
          KEY_EXIT                 0x1BDC
          KEY_OK                   0x1BDD
          KEY_UP                   0x1BE1
          KEY_DOWN                 0x1BE0
          KEY_LEFT                 0x1BDF
          KEY_RIGHT                0x1BDE
          KEY_CHANNELUP            0x1BED
          KEY_CHANNELDOWN          0x1BEC
          KEY_VOLUMEUP             0x1BEF
          KEY_VOLUMEDOWN           0x1BEE
          KEY_MUTE                 0x1BF1
          KEY_PREVIOUS             0x1BDC
          KEY_RECORD               0x1BE8
          KEY_DVD                  0x1BF2
      end codes

end remote

With the seeming endless ways to operate OSMC, I’m having trouble figuring out which one I like more… Gamepad, Remote, and Yatse are duelling for top position. They each have unique pros and cons.