Help needed open vpn installation

i installed open vpn addon in osmc now i have ovpn file configured by my router now i need to install it on my osmc how should i send it in osmc and where and how?

https://discourse.osmc.tv/search?q=openvpn%20client%20howto%20order:latest

how to give configuration file to the folder of settings of open vpn addon on osmc for .ovpn file

Hi,

Who is the vpn provider?

Also if you check the link I provided, it should give you all need to work this out.

Thanks Tom.

my router gives certificate with router static ip and creates open vpn configuration fie .opvn which i am not abe to put in settings to open vpn system in osmc , where as in windows its configured . what should i do and what are the commnds? help needed.

my router also can be configured as vpn network as it has both option as home network or home and internet network. with open network settings.

thank you in advance

Hi,

Is the router acting as a vpn server or client?

Thanks Tom.

please help me to tell me how to remotely access osmc and transmission…please help i am stuck?

Please suggest and help

Hi,

Is the osmc device and your router on the same network?

Because it looks like you are trying to make a vpn tunnel between devices on a router on the same lan?

If this is the case, I’m not sure what you are trying to achieve. Essentially what would be happening is the traffic on the lan would be encrypted, but once once it leaves your network; it would be unencrypted over the internet.

Could you give more details about your setup please?

Thanks Tom.

1 Like

i have my wd nas and raspberry pi 2 with osmc on one router at home. i have one computer at my office on internet at some other place how to open transmission on my computer in office and control osmc . i need control. so this is the only settings.

Please suggest what should i do?

Thank you

Hi,

Is windows PC on the same network as the osmc device, I just want to confirm you are able to establish a vpn connection to the office and no further configuration of the TPLINK is required.

Thanks Tom.

windows 10

office is mine i have my own internet connection with another tplink router at office but with simple settings. we are not on the same network where osmc is placed at different network.

Hi,

Have you managed to establish a vpn connection with any device to the office network?

Thanks Tom.

never tried

My guess is that the .ovpn file you got from your router should be copied to your office machine, and run an ovpn-client on the office machine, then when you want to connect to your home network, open the ovpn client and connect to your homenetwork. (As i said this is guess work)

When you done that you should be able to access transmission with your homenetwork address in your browser at work.

this settings needs to be installed on both the devices…thats the problem i installed it on windows 10 but not able to configure it on osmc with the file.

If your router acts as VPN-server, and your OSMC-device is on your local network. You should not need any vpn-client on your OSMC device. Unless you are running OSMC as client to another VPN provider?

If your OSMC device is acting as a server, you dont need any VPN server on the router, just portforward udp 11934 to you OSMC device.

Either way you shouldn’t need two servers running on you home network.

Perhaps the router is in a remote location and the OP is trying to connect to it using his osmc box?
The issue could be that the LAN IPs for both sides of the connect are the same. Network router requires them to be different.

Office - 10.1.10.0/24
Home - 192.168.1.0/24
If both LANs have the same subnet, I don’t think the routing will work.

Moving the .ovpn file to the OSMC machine can happen any way you like. I’d use scp or sftp, but you could put it onto a flash drive and “sneaker-net” the file over if you like. I don’t know anything about the openvpn client stuff on OSMC, but I use openvpn clients on Linux daily. Just install the normal openvpn package using apt, then start the service using something like this:
sudo /usr/sbin/openvpn --config /etc/openvpn/r-pi.ovpn &
Simple. So you don’t need to type that over and over, put those commands into a file somewhere in your PATH. Obviously, the r-pi.ovpn file needs to have the correct setting, login credentials and must point to the openvpn server public IP.
On the ovpn-server, just ensure the openvpn port is open. The default for openvpn-server is 1194/udp. Many hotels and companies will block all outbound UDP, so having the openvpn-server listen on 443/tcp will almost always work, however, TCP is much slower than UDP for VPN use due to the packet connection overhead.

Or did I get everything wrong?

Asking for help, but not answering the questions asked won’t get a solution.