Help setting up shared media lib from Windows

Alright, after a really tiresome effort of manually setting EVERYTHING up again on windows after my USB stick corrupted in my Raspberry I got things pretty much up and running again.

The only problem I have right now is that I need to set up network sharing from my windows computer to my Pi so it’ll just update my library like it did before and see all my new stuff but this time through network instead of from my HDD while all of the software and files are on my Windows comp.

I know b@lls about network sharing, seriously, I’ve never bothered. That’s where I get into trouble right now :stuck_out_tongue:
So I figure using SMB would be easiest I assume but what will I actually need to fill in on the forms.

As of now i have my static IP setup (always had a static IP) right clicked the dirs which are on my G: disk (e,g,. G:/movies, G:/tv) I didn’t set a network password or anything since my network is closed anyway.
So I filled out the SMB form, I added my static IP, added a dir, I picked “movies”, no port, no user and no pass. Hit ok. No dice, can’t connect.

What am I doing wrong and how do I fix it :stuck_out_tongue:

Nevermind think I got it, I didn’t need to enter a shared path, that made the dirs show up now I just need to get them to auto update in my library hehe

Ok now I’m stuck.

It shows everything in my Videos dir, I can watch anything, no problem. It however doesn’t add them to my library if I scan it’s instantly done. I have all the files in my library under TV SHOWS and MOVIES (I already had them in my library) but they still link to my HDD so they say they can’t be found. I can’t seem to find any way to link the new location to the old files or even add the new location in general so it would add new files…

Someone please advice :slight_smile:

Jump into IRC dude.

Debug log will indicate the problem

My guess is the sources on the Winbox have not been added as network sources.

I went for a quick reflash, I manually did everything else as well anyway so might as well mark what i’ve seen manually as well :stuck_out_tongue:

Lemmi wait for that to finish, readd the SMB’s and see what it does, if it still fails I’ll pop on IRC, cuz I really know nada about networking lol.

That instantly worked.
It might have been conflicting with the other files which had the exact same names but where stored on a space that was no longer available.

Lol is there anything you can do to be able to fast forward over SMB? Maybe increase the buffer size? I already dedicated 312mb of RAM to video since the box isn’t doing anything else anymore.
It pretty much crashed after I tried to fast forward 10 minutes into a movie.

Use NFS :smiley:

Hmm that might be an idea, lemmi try and set that up.

Just remember that the pi has to search through the media file to find the time stamp, then cache it, then play it.

Yeah ofcourse, it doesn’t have to be lightning fast but if I can watch something, skip 10 minutes, wait 5 seconds and watch again I’m fine with that really.

If you are stacking up the skips that can cause things to go pear shaped.
You can adjust the amount that gets skipped >

Another thing to remember is that some video files have chapters that you will be skipping in place of the 10minutes.

Just set up the NFS, blows that it’s a trial btw -_- lol.
Gotta find a suitable free replacement for that one.

Is there a way to delete the SMB’s though? I can’t seem to get rid of those.

As for the time modification. I’m usually good with 10 minute jumps for super fast forward and whatever the normal step is for skipping intro’s and such. I do know everything has chapters, pretty much everything x264 has chapters but I didn’t know it actually picked up on those instead of the 10 minutes. It should say “skipping to chapter X” instead of 10 minutes :stuck_out_tongue:

Ok I really need some help because this is going horrible.

First of all my TVshows don’t show up in the library through NFS, my movies do but my tv shows do not and I’m unable to even check the “TV shows” box in the menu, it’s greyed out.

I tried playing a 1080p episode of a show just now, first time I opened it it hung a bit then it crashed and restarted, second time it hung, the sound started playing, then the sound started being all choppy and it just kept going like that all freezed up, it’s still going while I finished watching the 20 min episode on my comp about 15 min ago.

The file wasn’t even big, 913MB. The HDD was doing pretty much nothing, it was just downloading something with 1MB/s and I can easily move around stuff on it with 30MB/s so that shouldn’t be a problem.
Afterwards I played the vid on the actual computer, no problems, not even a stutter…

Something is definitely going wrong here because this should play right?

My config settings look like this btw, maybe it’s useful:


and my NFS is set up as CaNsA suggested.

You know that post above with that link to a magical place?
Click it and join us.