HEVC x265 horrible on OSMC Leia Beta on RPi 3


#1

Hello guys! I updated my stable Krypton a couple of days ago to Leia Beta -347 then downgraded to -345 (because of known issues). I did this so I could try out the new beta and netflix addon. That worked fine, but when I went on to play my old library (streaming from my pc), I noticed that a whole season of Supernatural HEVC x265 1080 .mkv files that previously worked fine and had no troubles, played awfully on the new Beta… As you see below in my samples, the Leia one has green squares and just a lot of awful looking crap, whereas the one I recorded a few minutes ago (after doing a clean install back to Krypton) is working just fine.

Broken: https://www.youtube.com/watch?v=E8irTKz8ZEc&feature=youtu.be

Working: https://www.youtube.com/watch?v=lMWyfLdEH8k&feature=youtu.be

I also tried updating to the Beta from a clean install but the same issue was there. I have no downgraded to a clean stable Krypton for a second time so that I can play my local files, giving up the possibility of Netflix addon for now.

Just thought I would report this.


#2

There are some patches to improve HEVC performance but they are already included. Only parts of HEVC can be accelerated on the Raspberry Pi using the QPUs.

You could try a modest overclock; but if you want to play HEVC or HEVC 10-bit content reliably, you should consider the Vero 4K +.

The green squares appearing may be an issue with Kodi v18. As this is still experimental, it should be fixed shortly.

Sam


#3

Thanks for the quick reply!

To be honest I am not 100% sure that the issues is related to HEVC directly. But I did try some other files which did work so I just assumed. If that is the case that it is a v18 issue that will be fixed I will be happy to upgrade when it does get fixed :slight_smile:

And yes, the Vero 4K + is on my want-list. But since it is working on Krypton I don’t really understand why it would not work on Leia unless there is some kind of an issue, since the hardware is still the same :stuck_out_tongue:


#4

the kodi alphas/betas usually have massive issues - i remember one of the 17 alphas couldn’t even play sd content (avi etc.) at all and would only play 1080p mkv, hell sometimes it doesn’t even compile or install.

don’t use beta software just to get new features, there will be major breakage, stick with stable if you want a, well, stable experience!


#5

I knew what I was getting myself into and I did not update to the Beta just for the new features but also to experience things like this. Find bugs and oddities so that they can be fixed. Neither did I create this topic to complain about a Beta version with bugs/issues, but to report it so it can be looked into so that it hopefully will be adressed by the final release :slight_smile: