HiFi DAC+ not recognized after update

I’m aware of the other thread regarding this issue, but that thread was closed because the issue was seen as resolved since the new kernel update-- although I’ve updated to the new kernel and my HiFiBerry DAC+ is still not being recognized! After using the aplay -l command it shows “no soundcards”… Is there a way I can troubleshoot this? Is there a log I should post here?

Are you using the updated version from apt, or the modified kernel from the previous thread? The kernel isn’t yet updated in de distribution, since the one that’s working now, is experimental.

If you want a confirmed working kernel for the Hifiberry, you must, for now, use the separate kernel that is offered in the other thread.

I installed the kernel from the other thread, restarted and tried “aplay -l” but there were still no soundcards listed, so I did a manual apt-get update, upgrade after that with another restart but still no luck

dmesg ¦ paste-log and provide the URL

https://paste.osmc.tv/umekucupum

Have checked again for updates to ensure you are on the latest version and rebooted?

Your kernel is out of date. Try checking for updates again please.

So I ran “sudo apt-get update”, “sudo apt-get dist-upgrade”, “sudo reboot”, and after the reboot searched for the HiFiBerry with aplay -l, but still nothing
new logs are here: https://paste.osmc.tv/omiqokocem

Your kernel is still not up to date.

[ 0.000000] Linux version 4.9.29-4-osmc (root@vero3-db) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP PREEMPT Tue May 30 19:42:56 UTC 2017

Because these aren’t full logs, we can’t see APT History.

Well crap, I’m sorry, am I missing any steps in upgrading it? I’ve tried “apt-get update” and “apt-get dist-upgrade” with a reboot as well as the steps in the other thread

Provide URL from grab-logs -A

https://paste.osmc.tv/ereloxipad

This is looking strange. Can you run and show output of
sudo apt-get update
sudo apt-get dist-upgrade
ls -lah /boot

Still strange, try sudo apt-get install --reinstall rbp2-image-4.9.29-5-osmc

Your problem is:

Start-Date: 2016-12-07  15:34:27
Commandline: /usr/bin/apt-get-real install -y --no-install-recommends bluetooth
Install: bluetooth:armhf (5.23-2)
End-Date: 2016-12-07  15:34:30

Well – that’s where it starts.

I think you may have lost some metapackages which track the active kernel properly.

So I tried that reinstall command fzinken recommended but to no avail, is there something else I can try?
new logs are here: https://paste.osmc.tv/bidozisuxe
maybe i should’ve mentioned it before but when installing the kernel I get the messages in the image, are these relevant?

The messages are normal.

Since there’s something a bit odd about the dependencies on your system, you might find that the easiest way forward is to see if a fresh install to a different SD card resolves the issue.

Man…is that basically my only option left? I’d really like to avoid doing a clean install

Would it be worth my time to try the command from this thread?:

“sudo rpi-update”