HiFiBerry Digi+ - How to Set It Up for OSMC 0.9.9/Kodi

I have a Raspberry Pi 2 B+ loaded with a working OSMC 0.9.9/Kodi install.

I recently purchased a HifiBerry Digi+ board and installed in onto the RPi2.

Then I went through their configuration that appears to be old because newer posts are saying they have not tested it on OSMC.

So I thought to ask here to see if anyone has successfully configured this.

When I do the aplay -l it says " no soundcard found".

Thanks.

Seen this?
https://osmc.tv/help/wiki/pi-soundcard

There was no listing for the HifiBerry card to select in Kodi.

Anyway, I did get it to work after some more searching.

At https://www.hifiberry.com/guides/configuring-linux-3-18-x/, while the Blacklist has nothing to do with the OSMC, I added dtoverlay=hifiberry-digi to the /boot/config.txt and I create a file /etc/asound.conf with

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

After reboot I tested for the card and it showed up.

Then I went into OSMC settings and selected the HiFiBerry overlay, then I went into Kodi system settings for Audio and was able to select the board as the audio output.

Works great, sounds great. Happy, happy, happy.

Thanks.

I tried all of the solutions on here and on Hifiberry forums and just couldn’t get the ALSA option up in Audio output in settings or get the soundcard recognised in SSH. So I wiped everything, did a fresh install, manually updated OSMC and OS, rebooted, selected hifiberry-digi-overlay in OSMC settings, rebooted again and it finally appeared. All working now :smile:

[Note: I had a fresh install from RC1 that I had been manually updating, so somewhere in that update chain something that wasn’t enabling the Digi+ to be recognised at the driver level].

I do it too…
But after selected in KODI settings ALSA:default(snd-rpi-hifiberry_digi S/PDIF) my raspberry reloaded…
So…
After reload in KODI setting is audio autput :HDMI…
What i did wrong???