High memory usage when connected to an external hard drive on RPI2

Over the weekend my SD card became corrupt, so I reinstalled osmc on a fresh SD card yesterday and proceeded to install packages I have used in previous installations. Afterwards, I updated the fresh install to the newest August update via the command line (my previous install was on the July update).

After configuring my install, I found that their is high memory usage (almost max and the culprit is kodi.bin) upon initiation of transmission which persists even after exiting transmission and killing the daemon. The only way for me to free up some RAM is to unmount my external hard drive, at which point the RAM usage drops right down to ~200mb. Curiously this also occurs during after playing some video. When this occurs video playback ceases. It may be worth mentioning all data from transmission is downloaded onto the external hard drive and all media playback is also from the external hard drive.

I have only installed packages I have used on previous installations, so I don’t believe these are the culprits. I have only installed two add-ons which are the themes box and refocus, uninstalling them did not help. I tried renaming .kodi/ and rebooting so the default .kodi dir and files would be created in its place, again nothing. I haven’t messed around with any kodi config files.

This is really bizarre and I am at my wits end. The only thing I can think if is this is related to the August update which was pushed out a few days ago. I was wondering if you guys could help me troubleshoot this?

The log file:

I have installed the following packages via apt-get:
transmission mutt cron git vim python3 python3-pip python3-dev python-dev libxml2- dev libxslt1-dev zlib1g-dev ssmtp openvpn psmisc fail2ban

I installed cron and transmission from the ‘app store’, just realised I installed transmission twice.

Additionally installed pirate-get from pip3 and git cloned vundle for vim. I have only altered the following config files: .bashrc .vimrc .muttrc ssmtp.conf. All this info is probably within the above log file, but have been included just to be thorough.

Are you powering the hard drive from just the USB ports on your RPi2?

If you are you may get better results with a powered hub. Or if it is the type with two USB plugs, attach the data one to the RPi and the power one (thinner lead usually) to a power adapter.

The HDD is not powered by the pi: it has its own plug.

Well that should rule out any power issues which can cause continual reattachment which might have caused these issues.

You say the issue starts with Transmission but continues when itis stopped. You also say you installed Transmission twice. Have you removed one of the Transmission installs? Or is one still being run by kodi whilst you have killed the other binary?

I have attempted to but I am getting issues with apt-get complaining about unmet dependencies transmissions common and transmissiont-gtk any time I type sudo apt-get whatever. Tried marking these packages as reinstall in dpkg, but that didn’t work. I have a script that install all my desired packages so I may do a fresh install tonight and omit transmission and only install it via the app store. I’ll try this out tonight and post back the results

Sounds like Transmission became a little unhappy with two different installation methods. I’m sure there are other people here who would be experienced enough to tell you how to resolve it without a reinstall but I’m afraid that’s beyond my ability. If I were you I’d reinstall as per your plan.

A reinstall to an older version of osmc(july) and installing transmission via the app store seems to have solved my issue. Thanks for your help.

You’re very welcome. Hopefully now it is working you should be able to safely upgrade (sudo apt-get update && sudo apt-get dist-upgrade) to the latest version of OSMC without issue.