How to disable library functions altogether?

I use my Raspberry Pi based OSMC box to view my own videos plus recordings done off air of certain news shows.
These mp4 files are stored on a “mediadrive” 1TB USB connected hard drive using a folder/file structure for navigation.
I drop off video files in this folder hierarchy using a samba share on the media drive disk into the respective folders.
I have updated my RPi OSMC to the latest version just a few weeks ago.

But I have a problem concerning what is shown when I navigate the files:
Kodi/OSMC is replacing the names of my folders with some completely unrelated names and is also showing some very strange artwork for the folders…
My folders are named:
11thhour
chrishayes
deadline_wh
hardball
latest
lawrence
morningjoe
mtp
rachel
streams
thebeat
various
weekend

But they are shown in the Kodi view (as shown in attachment image):
Charlie Lawrence
chrishayes
Deadline: White House
Hardball
The Latest Buzz
Meet the Press
morningjoe
rachel
streams

It makes no sense to me at all and I want to get rid of it altogether so I can view the folders and files as they are named on the disk.
I have looked at various types of settings without being able to fix the problem.
Please advice the step-by-step way to get to where I can switch off this library feature altogether.

I have also revisited a similar question I posted on the Kodi forum back in 2014 and tried to replicate the way it was solved back then but since I am now using the OSMC default skin rather than Amber back then it does not work.

You can remove folder from library in Settings -> Media -> Library -> Video

Well I’m at the place I have been several times already…
First Settings-Media-Library:
image

Then I open videos and also look at the left arrow menu:
image

But I cannot find any “Remove from library” command…
Must still be in the wrong place.
Note;
I really want to remove everything from any “library” screwing up the names I have given to folders and files…

Can you connect a keyboard? You would need to select folder and press C on keyboard.

You are looking for an option to remove/delete source. As @ooZee says, you need the context menu while you have the source you want to delete highlighted.

THANKS a Million!
That was the solution. I could not have figured out that a keyboard was needed…

Well you don’t need a keyboard just a remote that opens the context menu (like the OSMC remote or even your TV remote via CEC).

1 Like

I tried the Yatse remote app on Android too, but I could not find how to open a “context menu” there either. What does the button for that look like?
(not that it really matters now that I have it fixed already…)
This is how the Yatse display looks like:

The one with the three dots and lines

2 Likes

Thanks, then I know…