How to get the "Movies" menu in OSMC

Hello Community,

So, recently, I updated to the new OSMC, and deleted everything I had on my pi b+. I used to have a “Movies” title on the top of the menu in the home screen. From there, I could see all of my movies on my device. When I updated, I could no longer get that menu.

Maybe it has something to do with the way I configured OSMC. I Moved the “Movies”, “TV Shows”, “Streams” and “Music Videos” folder into a custom folder called “videos”. Then, I created a new folder called “Stream Cache”. I duplicated this system of folders on all of my USBs that were connected to my pi. I then added the sources by clicking “Add Videos”, and connecting all of the movie folders, tv show folders, stream folders, and music video folders.

I also have set up Amazon Instant Video, and added those movies and tv shows to my folder structure. Is there something I am doing wrong?

Over and Out,

Minor news,
I customized the home screen, but now when I click on movies, it brings me to the OSMC movies menu, rather than my file structure. How can I fix this?

I have the same problem.
I’ve just upgraded to pi 2 model b, put osmc on this and is working, but the menu for TV shows and movies are not available. In the settings I found the options for them, but they are grade out - any ideas on how to activate the menu?
I have gone in to videos and added the locations of the folders in question, on my original kodi this resulted in the movie and TV show menus activating but this time nothing.


You need to right click/context menu on the sources inside files and set content then scan them to library. Once the library has contents the menus will show on the home screen. Upnp sources CANNOT be added to the library, if using upnp change to samba or nfs to populate the library.

Guessing you are running (or intend to) a local database, you still have to let Kodi scan your given folders for content.
Kodi will then scrape those folders and add what it can scrape to its library.
Only then the menus for ‘Movies’ and ‘TV Shows’ will appear as these depend on a used and filled library.

Edit: ok, what @Dilligaf said.

Thanks so much for this