How to scroll up the menu with a mouse using default skin?

Hello everyone. I installed OSMC on my Raspberry Pi 1 model B using NOOBS today. Everything works fine except for one thing. It seems not possible to go up in the menu using a mouse. For example, in Video Addons list I can only go down the menu by moving a pointer near the bottom of the screen. However, it’s not possible to go up - moving a pointer to a top doesn’t do a thing and a scroll button does not work neither. I can just go back to the previous screen by pressing a right button. I can scroll up with a mouse in Confluence skin. Is it a bug or a feautere?

It’s neither a bug nor a feature.
If your install doesn’t work, then there is a problem to be found and debugged - none of my installs show this (but you do have to move the mouse well up to get it to scroll up).
I don’t install from NOOBS, but if the mouse works at all, then it should be full-functioned.
derek

I tried again, no luck. Scroll button does not work. Also, I moved a mouse pointer to the top of the screen but nothing happens. The following is written to /home/osmc/.kodi/temp/kodi.log when I press a scroll button on my mouse:

15:35:59 T:3023589376 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 8

My mouse is a wireless Logitech M310 model.

EDIT: it seems to be a known problem: https://encrypted.google.com/search?q=CLinuxInputDevice%3A%3ARelEvent%3A+Unknown+rel+event&hl=en. Is it possible to move up the menu w/o using a scroll button?

I don’t get anything happening onscreen if I use the mouse scrollwheel or press it (haven’t looked to see what event it generates).
My mouse cursor goes up and down and left and right - albeit with some lag. What I haven’t tried is to go beyond the screen limits for scrolling a long list.
I think you might want to use confluence instead of the default screen to get full actions.
This might change in future - as it is the mouse response has been improved.
Derek

Sure, in Confluence there is a scroll bar on the right side of the list that can be dragged with a mouse. But to make sure definitely - do you know a way to scroll up a list without using a keyboard in a default skin? Keyboard works perfectly but I am pretty sure that moving up with a mouse is a feature developers could not miss.

If you search back far enough, you will find that the default OSMC skin was designed for use with a remote - and it was considered that configuring it for mouse was unnecessary. Later it was modified so that use of a mouse became reasonable - but not all aspects it would appear.
Derek

Ok, I didn’t know that. Thank you for giving me the background. Now everything is clear.

The mouse works with the OSMC skin now. But the NOOBS version of OSMC is out dated. Go to My OSMC -> Updater -> and update and then it will work again

Sam