How to synchronise TVHeadend with OSMC File manager?

I am new here, so bear with me!

I have OSMC and TVHeadend running on a Raspberry Pi3 with a USB hard disk.

Using the web interface to port 9981 from a PC I have set up several TV shows to record the series using the “Autorecs” button and they seem to be recording. The various recordings show up in the TVHeadend “Finished Recordings” tab. So far so good.

However, when I go to the GUI on the RPi/OSMC and go into Video / Files / MyUSBDrive then I don’t see all of the recordings which appear on the web interface! Same if I use the GUI to go to Settings / File Manager. It maybe shows half of the recordings that should be there.

Do I have to synch the two sets of files somehow?
Am I missing something (VERY likely)?

Thanks in advance

Hi, goto to the tvheadend’s web GUI and look at

Configuration -> Recording -> Recorder Profiles-> (Default Profile) -> Recording System Path

That’s the location where the recordings are placed.

Then you should activate a PVR client, I personally prefer the TVheadend HTSP Client.

This can be done at

Settings -> Add-on Browser -> My-Addons -> PVR Clients -> TVheadend HTSP Client

You’ll find now a new item PVR & Live TV in the main menu.

I think I may have found the issue.
I have TVHeadend installed and seems to be OK.
During it’s configuration I set it up to record to my USB drive which I had mounted to /mnt/recordings. Some of my recordings ARE on that drive.

So I was checking out the file system and used df -h to see what was happening and it seems that my USB disc has “Auto Mounted” itself as /media/WD 150G USB
More of the files are in that directory.

How does the “Auto Mount” capability work?

My thought is to 1) copy all the files to the USB drive then 2) change the “Recording system path” to /media/WD 150G USB.
I hope by copying the files I will save the recordings (that isn’t important), free up space on my microSD card and maybe get all of the recordings to show up in the GUI.

Does that sound like reasonable plan?

If you mount a USB drive with fstab in /mnt/ it should turn up there if you boot with it plugged in. Mine does that, but it may be just luck that fstab grabs it first. There’s probably a bit of a race between the two mounting systems.

I’m not clear about where your files are - theye seem to be on just one disc which has been mounted in two different places, or have some gone to the default TVRecordings directory in your home directory? You can round them up and put them all in the same place. Not all will be visible through TVHeadend but you can add that directory as a source and access them through Videos->Files then.

I think your suggestion that there is a bit of a race between the two mounting systems may be correct.
The USB drive seems to power down it’s disk when not used for a while, but spins up when accessed.
So I am guessing that if the USB drive IS spinning then it uses it’s mount point (which was /mnt/recordings) and if it isn’t spinning then it writes the files to /mnt/recordings on my SD card.
Also, if the disk is spinning then the USB disc appears on the mount point /mnt/recordings and refers to the disc properly.

Now the problem I have is understanding what “Auto Mount” does. I suspect that it picks up the USB drive name (WD 150G USB - it’s previous use was as a back drive for a Windows system) and it Auto Mounts it as /media/WD 150G USB.

If that is the case then it would help me understand why sometimes it would record properly on the usb drive (when it can “see” the usb drive) and would record on the /mnt/recordings on the SD card when it doesn’t “see” the USB drive…

To try and cure the issue I have changed the “Recordings Systems Path” to /media/WD 150G USB in the hope that it ALWAYS tries to write to the same location.
What I don’t know is if OSMC / Raspian is smart enough to wait for the USB drive to spin up before writing to it?

It should record something later today and I will check what happens.

Damn! It was meant to record at 9pm, but it crashed instead :frowning:
Where does OSMC keep it’s logs?

OK. We need to find out what’s going on here. You don’t need to know where the logs are, first turn on debug logging Settings->System->logging (turn on Settings level:Standard at bottom left if you can’t see the logging option). Then just go to MyOSMC, and upload logs (the clipboard icon).

After you upload logs, share the URL of the upload here.

OK Thanks. I have switched on logging. I’ll let it run until the morning and upload the logs then.

It ran until 02:31. I rebooted it at 08:31 but it died again at 09:22. Restarted at 9:37. I have switched off logging in case that was upsetting it.

The logs are at

I skimmed the logs but I don’t know what I am looking for! It seemed to recognise the usb disk as WD 150G USB, and it seems to have mounted it as /media/WD 150G USB as hoped for.

Could you have a look at the logs, please?
Thanks in advance

I have given up on that image! The RPi kept locking up after about 5 minutes of any attempted recording, so I was thinking that maybe I have damaged it’s file system by now.
I have re-formatted the SD card, re-downloaded the OSMC installer and I am starting again.

Maybe I won’t $crew it up this time …
Thanks so far

@BruceEmsworth: In the logs we see that TVheadend knows about recordings in two locations

  • /mnt/recordings (which is on your SD card if it is a pi)
  • /media/WD 150G USB

/mnt/recordings is the default TVheadend’s recording path. For me it looks like you have used TVheaded with the path a long time. Probably your SD got filled up till out of space condition while the next recording. So, please care about the recording path to not land on the SD card before create a new timer.

Thanks Jim, as I posted earlier, I gave up with that image and re-loaded my SD card.
Of course not everything has gone smoothly!
Currently stuck as the EPG isn’t showing up, it just says “Unavailable”. Not sure if it is still scanning for it or if a link is missing. I am trying to be patient in case it needs to fetch it from somewhere.

Other inconvenience is that it got it’s own ip address from dhcp and it seems that setting a fixed ip address isn’t as straightforward as it might be.

I am using OSMC 2018.01-1 and it seems that the on line “documentation” is out of step. I assume that is just part of open source, but I wonder where the most up to date data is