How to use external database with vero

after I ensured that I hat access to my NAS via smb
I tried to copy my advancedsettings.xml to /home/osmc/.kodi/userdata

however I didn’t saw my media after the reboot. Doesn’t it work like this on the vero?

This is exactly how it works. Are you sure you don’t have a typo or issue with your advancedsettings.xml?

Thanks for the confirmation. I will look into this

Hi Sam,

I was able to track down the problem.
At startup time when Vero tries to access the databases the network is not yet initialized resulting in errors like

ERROR: Unable to open database: MyMusic48 [2003](Can’t connect to MySQL server on ‘’ (101))

Vero is so fast that this happens even if I use a wired LAN connection without DHCP (manually configured ip)

So if there database resides externally it is necessary that Vero waits until the network is up before it tries to accede the databases

I have replied to your other thread explaining how to wait for a network connection


By trying to use an external database via advanced settings.xml I found out that Vero is trying to access the database before the network is running. in the log I get the following error multiple times
also the configured Live TV access is also accessed to early resulting in a error message in the UI and in the log

ERROR: Unable to open database: MyMusic48 [2003](Can’t connect to MySQL server on ‘’ (101))


ERROR: AddOnLog: VU+ / Enigma2 Client: Open It seem’s that the webinterface cannot be reached. Make sure that you set the correct configuration options in the addon settings!

When I restart kodi (without reboot) everything works fine.

This indicates to me that Kodi on Vero tries to access the eth0 wired LAN (with fixed ip) at a state way to early.

Where can I put a delay to solve this temporarily ?


Hi chris

SSH in and run sudo systemctl enable connman-wait-for-network

After a reboot, this will now wait for a network connection before starting Kodi.

Hi Sam,

This solved the problem perfectly

just did a fresh RC2 install, according to release notes i thought this is set automatically… needed to activate it again

You can do it via the GUI (My OSMC -> Networking)