[HowTo] Install a vnc server on the Raspberry pi

In the moment this is the only fix if you need VNC

Is this for RPi3 aswell or for RPi4 only?

I’ve stayed in osmc VERSION_ID=“2020.11-1” and Kodi 18.9 and disabled updates.

Should work identical on the Pi4 with the workaround

But atm. nobody can tell what the change ready does:

in /boot/config.txt, change the line

Set the resolution to maximum 1080p.

Sam says don’t do that. but fzinken confirm it works, so give it a try

1 Like

Well we know what it does it switches to the fakeKMS which allows the old method of grabbing the screen content which will impact the video playback performance

1 Like

There is something about it, a little outdated Pi Forum

worked for me

Did you change the “dtoverlay” bevor or after the Installation?

May I can change the Installationroutine to support the PI4 with the “kms/fkms” behavior this will cost an reboot after all

Hello everyone!

This is my first post in this community. First of all, thank you for this awesome post! I had to restart VNC in my OSMC and nothing worked. After a lot of trial and error I finally got it.

Unfortunately I now have the problem that the VNC service shows up 5 times in my task manager.

Maybe it is because I installed and uninstalled VNC several times.

Can anyone tell me how to get the (apparently dead) VNC services out again?

Thanks for your help!

Did you manually start all these? or are they services running?
Try killing the processes first with

kill -9 402
kill -9 401

basically all those PIDs you see at the front. Then do a reboot and recheck to see if only 1 service is running or 10000 of them again :stuck_out_tongue:
(sudo kill… if you are not logged in with the root account)


systemctl stop dispmanx_vncserver.service
systemctl disable dispmanx_vncserver.service
rm -f dispmanx_vncserver.service

This should remove the service completly

Hi Sandbird,

the first thing I figured out is that five entries belong together. When I display in HTOP with F5 for the tree view, the whole thing looks like this.

With your commands I was able to kick out at least one service completely.

But since I’m a curious guy who doesn’t really know about the OSMC Putty commands, I’m trying to uninstall that service as well. I just can’t get it to work though.

Do you have another solution for me?

What I noticed is that the service I was able to remove was running as user osmc. The service I can’t get rid of is running as the root user.

I also tried your commands as root. Without result.

hmm, i presume you have made a root account and have installed the server using the shell script ?
If so try logging in with your root account and just run the installer again. It has a “Uninstall VNC service” option. It does the same thing that i mentioned but without all the hassle of typing things. Basically you want all the above removal commands to run with su rights…It makes it easier just logging in with root instead of elevating everything with su.
You could try running the Uninstaller 4-5 times…not sure if it will catch all of the services…but give it a try.

I have tried your tip. Unfortunately without success. But it doesn’t matter for now. VNC works again. That is the most important thing. I will try it manually again sometime and look for the appropriate commands before.

Thanks again for your work and your help. The solution was the change in the config.txt. :+1:

1 Like

So a new version of this script is online that take care of the KMS / fake-KMS GPU Driver for the GPU if you use OSMC in version 19.1 or above with KMS it will self change it to fKMS und force an reboot if you use OSMC in version 18.9 nothing happend that way.

Also you have the Menu-Options the change KMS/fKMS at will not visible with OSMC 18.9.

And last but not least, installing the VNC Server does’t force an OSMC update anymore, if you want to stay with 18.9 (or else) it’s untouched.

Menu with OSMC >=19.1
GIF 07.11.2021 21-08-08


These instructions worked out very good.

MarkusLange May '19

with the help and many tests from Sandbird, I present you a GUI for installing the vnc server on osmc (for raspberry pi only)

Login to your OSMC (putty or else)

Grep the install file:
wget https://raw.githubusercontent.com/MarkusLange/VNC-Server-install-script-for-OSMC/master/osmc_vnc_install_cli.bash

Make it executable:
chmod +x osmc_vnc_install_cli.bash

Start the GUI with:
sudo ./osmc_vnc_install_cli.bash

Now you see this:

Now you can follow the Options…

I only had to change my config-user.txt again to activate/access the analog RasPi output again.
For some reason it seems that in the standard installation of osmc KODI 19.3 the analog output can not be activated, audio comes only via HDMI. But I connect the Raspi to my stereo amplifier only because I only use it for streaming radio. So no need to turn on the TV as well, just to get the audio sound. I’m controlling osmc KODI via yaste only. yatse is geat as well.
Keep up the good work guys!


Hello developers, I am new to Linux, I am having problem while installing VNC server, please guide me to resolve an error, which states that ‘Sub-process /usr/bin/dpkg returned an error code(1)’, I have tried reinstalling the OSMC but nothing changed. I have followed the last post by @MarkusLange posted on May 2019. Looking forward for your reply. Thanks in advance.
Log file at : log file

Please upload logs via grab-logs -A and share the URL.

Sorry forgot to attach the link, here is the link.
Log file at : Log file

I am not opening a strange google drive link. I have written above how you provide logs via the OSMC build in solution. Please so so if you want help.