[HowTo] Install a vnc server on the Raspberry pi


#306

hmm i guess something changed in the core files and a recompile was needed.


#307

Cheers man that worked a charm


#308

My guess is that it might be libvncserver, since it’s updated in stretch. So if you did an autoremove it would remove the old libary-file therefor the server wouldn’t run.


#309

@wbeard52 @the_bo

libvncserver against which the binary is linked during compile was updated with Stretch so the binary need recompile. If you run on command line you will get the respective message


#310

Hi all,

VNC also stopped connecting for me following an upgrade to 17.6. Being a novice, I tried re-installing my P3 system from scratch and following the instruction to re-install VNC I’d used previously ([HowTo] Install a vnc server on the Raspberry pi). I’m now stuck as when I issues the ‘make’ command I get “make: not found”, therefore I can’t successfully follow the advice above. Any help would be appreciated. Thanks in advance.


#311

Than something is wrong with your new system


#312

OK thanks - OSMC is up and running using the latest download so should I report this problem as a new thread?


#313

Well I might have not written that clearly. It is nothing wrong with OSMC.
But you might not have followed the instructions correctly. If you install all the packages explained in the first step you will have the “make” programm on your install


#314

So I started here, is there a step before this?

cd /home/osmc
sudo wget https://github.com/patrikolausson/dispmanx_vnc/archive/master.zip
unzip master.zip -d /home/osmc/
rm master.zip
cd dispmanx_vnc-master
make


#315

Well first entry looks like this


#317

Thanks for the help however I now have:
osmc@BoseP3DAC:~/dispmanx_vnc-master$ sudo apt-get install build-essential rbp-userland-dev-osmc libvncserver-dev libconfig+±dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package build-essential
E: Unable to locate package rbp-userland-dev-osmc
E: Unable to locate package libvncserver-dev
E: Unable to locate package libconfig+±dev
E: Couldn’t find any package by regex 'libconfig+±dev’
osmc@BoseP3DAC:~/dispmanx_vnc-master$


#318

Because I quoted the first post of this thread it got mixed up.

  1. You should know what you do and carefully read the first entry in this thread
  2. the command is sudo apt-get install build-essential rbp-userland-dev-osmc libvncserver-dev libconfig++-dev unzip

#319

OK sorry if this has been painful. I’ll try again.


#322

Um, so copied from the first post and returned the following:

osmc@BoseP3DAC:~$ sudo apt-get install build-essential rbp-userland-dev-osmc libvncserver-dev libconfig+±dev unzip
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package build-essential
E: Unable to locate package rbp-userland-dev-osmc
E: Unable to locate package libvncserver-dev
E: Unable to locate package libconfig+±dev
E: Couldn’t find any package by regex 'libconfig+±dev’
E: Unable to locate package unzip
osmc@BoseP3DAC:~$

Any further ideas that I can try?


#323

BTW the +± part of the instruction is being reformatted when pasted above.


#324

This would be strange.
run
sudo apt-get update
sudo apt-get build-essential

and report back


#325

Thank you. Yep sudo apt-get install build essentials was successful following the update. I’ll try again from the top now.


#326

Thank you for you help; VNC up and running again.


#327

I have just received a new RPi3 and am doing a fresh install. OSMC installed, Sonarr installed, Radarr installed. When trying to install VNC, there is a problem. When connecting to RPi3 using VNC I get an error that the connection was refused.

When I tried issuing the command:

osmc@osmc:~$ sudo systemctl status dispmanx_vncserver

I get this message:

dispmanx_vncserver.service - VNC Server
Loaded: loaded (/etc/systemd/system/dispmanx_vncserver.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Mon 2018-01-15 16:11:22 UTC; 7s ago
Process: 940 ExecStartPre=/sbin/modprobe evdev (code=exited, status=1/FAILURE)
Jan 15 16:11:22 osmc systemd[1]: dispmanx_vncserver.service: Control process exited, code=exited status
Jan 15 16:11:22 osmc systemd[1]: Failed to start VNC Server.
Jan 15 16:11:22 osmc systemd[1]: dispmanx_vncserver.service: Unit entered failed state.
Jan 15 16:11:22 osmc systemd[1]: dispmanx_vncserver.service: Failed with result 'exit-code'.

I’m new to Linux but I have followed this tutorial to the dot (well, except for using nano instead of vi :slight_smile: )

Any help would be greatly appreciated.


#328

I think you copy/pasted the service text in the editor but failed to copy the starting [ in the [Unit] line.
Lets try removing the service and start again

Do this part:

sudo systemctl stop dispmanx_vncserver.service
sudo systemctl disable dispmanx_vncserver.service
sudo rm /etc/systemd/system/dispmanx_vncserver.service
sudo systemctl daemon-reload
sudo systemctl reset-failed

But also do this after:
sudo rm /etc/systemd/system/multi-user.target.wants/dispmanx_vncserver.service

(just do be sure that this worked…open a winscp (or filezilla) sesion to your pi and go to this folder:
/etc/systemd/system
Make sure you check every file/subfolder in there, and delete any file with the name starting with dispmanx_vncserver.

After that redo the service installation part like before.
Its that stuff on the 1st post under the phrase:

Now we’ll create the service file to be able to ‘autoload’ the server on boot

Make sure you copy/pasted aaaaaall the text this time :slight_smile: