Hyperion with ws2812b on RPi 2

Hi All,

Has anyone managed to get OSMC Alpha 4 on the RPi2 working with ws2812b LEDs using GPIO18 (pin 12)?

Everything looks correct, if I run hyperiond manually and watch stdio output there are no errors. This config all worked perfectly using Raspbmc on my model B.

EDIT: Just to clarify, the LEDs do not light up at all, either from Kodi or using hyperion-remote etc.

Cheers
Zappa

Hi, i’m interessted int that too. PUSH

I’ve manaed to get this fixed, the memory addresses used on the pi2 have changed due to the increased memory size.

The detail is at the end of this thread:

https://github.com/tvdzwan/hyperion/issues/6

If you don’t want to compile it yourself, below is a link to the binary:

Zappa

1 Like

Hi @Zappatron,

I know this is an old discussion, but I can’t seem to get my RPi2 + OSMC + WS2812B LEDs + Hyperion to work.

I’ve followed that thread you linked to, tried your compiled binary, plus most of the other possible solutions on that thread, but to no avail.

My current setup matches the one as described on the Adafruit website, and I can get the LEDs to work using the rpi_ws281x library in that demo, but nothing seems to work for me with Hyperion.

Any help/advice/guidance appreciated.

/Dan

Hey @dansinclair25,

It’s been broken since the November 2015 update. I haven’t done any investigation as to why due to time constraints but if you’re willing to use an old version (so October or earlier) it should work.

Zappa

Thanks @Zappatron.

Is that using your compiled binary or just the standard install?

Using my binary. There are memory address changes for the Pi2 that are required

You’re awesome! I have it working using the October release of OSMC and your binary :smiley:

Thanks @Zappatron !!

how to install on OSMC ?