I KNOW I am being thick here but.... fstab / Kodi

I am clearly missing something obvious (and have trolled over the board for well over an hour but I just dont see what is wrong but I am sure its simple!

So I have my 4k box and I use a WDCloud device as my NAS. Ive only ever had TVShows and Movies set up as media sources but now want to add another Video source (on same NAS diff’t share) with my home movies on it.

I set the original system up so long ago I cant for the life of me recall what I did to get it working other than follow directions off the community…wish I had bookmarked it but i didnt!

anyway…

I have my fstab file all working :

in my /mnt directory i have the following directories :

HomeMovies Movies TVShows

and all with the correct content in them if i look at the directories they contain the correct file names off the NAS so that seems good and I assume it means my fstab file is good…

However when I go into Kodi ( Kodi/Videos) I only see my original Movies and TV Shows as drives for Media Sources. No sign of the HomeMovies mount.

Am I missing somethign I need to do to see this mnt in Kodi??

And apologies for this being a simple thing but if anyone can shed any light on this i’d appreciate it - thanks in advance.

Videos->Files->Add videos… doesn’t allow to to browse to /mnt/?

Videos / Files didnt show the HomeMovies mount but I have since fixed that by adding HomeMovies at the same level as Music Movies TVShows

So now I see the mount point of HomeMovies but when I click on it I just see blank screen (other than the … at top)

It doesnt show me the content of it… Content type was set to local only which should show the file names.

FWIW I can set up an SMB share to the location directly BUT that is just too slow for my 4k movies to stream over.

I think you are mixing up topics.
You go Videos -> Files -> Root Filesystem -> mnt -> your NAS and click OK.
I believe best is your share logs so that we can tell you whats going on.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks …

I worked it out from there … I knew it was something simple …

I just needed to add the source as a root as you inferred … blindingly obvious!

Thank you … all solved …

appreciate the input…

1 Like