Ignore Volume Up/Down

Hi !
I switched over from OpenElec to OSMC.
All is running fine but i got one point which is maybe impossible for me to solve.
OSMC is running on a Pi2. I’m using my standard Sony TV Remote with a lirc usb adapter.
I programmed the rc in the past to my needs. All standard function except the volume control. These i don’t want to use with Kodi, i want only to use the volume control on my TV.
Now with OSMC it don’t work:
If i hit Vol up: Volume on TV goes up and on Kodi it goes down.
If i hit Vol down: Volume on TV goes down and on Kodi it goes also down.

I tried my backuped keycap.xml without success. I tried all remote controls under OSMC settings without success.
Not steered by HDMI signal, if i cover the lirc all works fine.
I also tried the keycap editor plugin, also not successful.

How can i get Kodi/OSMC to ignore my Volume Signals ?

I would stop Kodi with

sudo systemctl mediacenter stop

Then run

sudo irw

and press the keys that are not working. I would then make sure it’s covered in your LIRC.conf



sudo irw

nothing happens

The keys are all working, the problem is i have to much keys working. Modi should ignore the volume keys.

Please post the lircd.conf, remote.xml, keyboard.xml that you are using - you can do so with the log uploader in OSMC settings.

You can disable buttons, keys and actions in Kodi with a custom keymap.xml or remote.xml.
Example to disable an action: