Image "OSMC_TGT_rbp2_20191104.img" not installable

So I downloaded the image file OSMC_TGT_rbp2_20191104.img.gz for my Raspberry Pi 3B.

I flashed it to my SD card (in Linux) using umount to unmount and gdisk to completely clear the SD card and then

$ gzip -dc OSMC_TGT_rbp2_20191104.img.gz | pv | sudo dd of=/dev/mmcblk0 && sync

to finally flash it.

I inserted the SD card to my Raspberry Pi but nearly instantly received the following error message:

The file install.log existed on the SD card but it was empty.

I tried this several times with the same result.

To rule out a hardware (or another) problem, I tried the same with the previous image file OSMC_TGT_rbp2_20190808.img.

That worked just as expected.

Therefore I assume there is a problem with the newest image file. Maybe just something easy like a permission problem on the partitions?

I hope the problem is not on my side. Please let me know if I can provide additional information.

Please post the log from the installer

Sorry, but I think I cannot provide this information.

I just picked a different SD card I had laying around and rerun the whole procedure. I inserted the SD card to my Raspberry, received the same error message again and put it back into my notebook. There is no log file on the SD card - not even an empty one like I mentioned before.

Also I cannot deliver a log file from an installer, because I just used the command line in Linux.

All I have is the output from dd (sorry, it’s in German)

$ gzip -dc OSMC_TGT_rbp2_20190808.img.gz | pv | sudo dd of=/dev/mmcblk0 && sync
 320MiB 0:01:53 [2,83MiB/s] [           <=>                              ]
655360+0 Datensätze ein
655360+0 Datensätze aus
335544320 bytes (336 MB, 320 MiB) copied, 127,796 s, 2,6 MB/s

There’s bug which should be fixed shortly. Thanks for the report.

You can install the previous image and upgrade to get the latest.


I’ve pulled the images for now and will have a new release shortly.

For now you can just grab an older image and update which will procure the same result



did it just like that. I still consider a reinstall later because of the better partition alignment… but I might as well wait for the next release!

Thanks for you help!

TBH, it’s hardly worth the faff to re-image. The system partition was always properly aligned, the boot partition has now been moved to start at 4MiB in combination with making it bigger. Since the boot partition hardly gets any writes, leaving it where it is is not going to shorten the life of your card.