Inconsistent performance, lockups, buffering lately

Did the last update add anything that may have impacted stability?
I’m getting pretty lacklustre and honestly frustrating performance from the Vero 4k lately.
Sometimes when starting a 4k movie ~40-50gb, it will actually show the timeclock that the file is playing but nothing is onscreen. Stopping it and restarting has resolved this in the past.
Some movies will audio sync issues, rebooting the Vero resolved.
Buffering is happening more now where it didn’t before and sometimes it will hang the box. Starting and restarting the file or reboot resolves.
All files are on USB attached harddrive enclosures. All via powered usb hub, a couple hard drives are new, all test 100% when diagnostics are run, cables swapped as well for testing.
Was hoping to have a solid 4k with HD audio box but lately it’s not really performing.
Transferring files from my Windows PC across the network also seems to have taken a hit and is very slow, like 1MB -10MB, fluctuates. I know it’s only 10/100 but was hoping for some more consistency.

Not sure the logs will show anything, as they haven’t in the past and I’m just dealing with the previous issues, if I can get to doing that today I will, but also wanted a hassle-free box that I didn’t have to keep working on, that’s why I went away from an HTPC.

Sorry for the rant, thanks for reading, appreciate any suggestions. :slight_smile:

Can’t think of anything that would cause this. What version did you update from?

Can you upload some debug logs?

We can get you up and running but definitely need a bit more info.

I’ll try to get logs tomorrow.
Update is the latest August update, I have them set to auto update, so haven’t applied any custom fixes or anything, all pretty vanilla.

Ran the debug fora few hours, saw some improved performance after I switched the out a few usb cables on the hub and Vero (swapped the remote usb adapter and the usb–>gigabit adapter from the hub to the Vero), but when I uploaded the logs (tried twice) I get this link: and appends ‘HTML’ in brackets
Which clearly isn’t right…thoughts?

Since you ran debug “for a few hours”, the log is probably too big to upload. (And probably too big for any of us to read. :wink: )

Ideally, reboot the Vero, switch on debugging, reproduce the issue (as quickly as possible) and then upload the (full) log.

1 Like

sigh I tried.
This goes to the ‘inconsistent’ behavior, it needs to be running for an indeterminate amount of time because its not 100% reproducible. If I knew exactly what was causing it I could reference or fix it.
I suspect this will end being a chasing ghosts exercise and result in the assertion that it’s my other equipment.
Turning on debug, rebooting and having no issues occur will yield a useless log, so I guess I’ll make do for now and try a few other things.

Thanks for the replies, sorry for the frustrated tone.

You can switch debugging on at any time. Clearly, getting your timing right might not be so easy.
One movie failed to start, some stuttering and some lag when opening Movies section.
Had one movie hang but debug was not running, rebooting seems to resolve this but I was under the impression the Vero didn’t need to be rebooted often.

Unfortunately, you didn’t include the kodi log. Nothing jumps out at me in the system log.

I can speak from experience with a 4K that had 4 drives connected to it that I never had this problem. And the only times I would reboot would be an update, testing (for development/support) or power outage. My 4K has had uptimes of 45+ days. (I moved the drives off the 4K only because I was rebooting for a little while often because I was helping testing no-related kernel issues, and I have 3 other OSMC systems that access those hard drives)

I’m not going to blame your hardware, but I would suggest if possible to remove a drive, test for a while to see if the problem happens. Keep doing that so see if maybe there is a failing drive causing a problem. This looks like it’s going to be an interesting problem to track down.

Instead of starting yet another thread, I’ll add on to this with additional comments, testing, perhaps even the right kind of logs. That said, I enabled debug and event logging, rebooted and of course being the 4th reboot of the day, the 4k files played ok, except for audio waiting about 10-15 seconds before kicking in. That’s new.

Seeing so many have no issues with the box and I post issues and either no one has else seen the issue or can’t reproduce it or I’ve not done logs correctly, frustrating.

I still have to wait 30 to 60 seconds after I click Movies or TV.

I still get frequent hangs when trying to play 4k material via USB attached hard drives. All are at 100% health. I even removed an enclosure with 2 hdds in it and have replaced with a new 8tb seagate external - all are powered units connected to a 7 port powered usb hub.

If I pause or skip 30 seconds the likelihood that the movie will hang is pretty high. Often I have to reboot to get it to come back.

Even with the new external hard drive the behavior is the same so it’s not hardware.

So logs are here but since the unit didn’t freeze or hang, I’m sure there’s nothing there.

If someone can suggest anything else, I’m all ears cuz I’m close to the end here :frowning_face:

Equipment and updates:
Latest October update applied.
Rapier skin
Denon x2300 receiver
Sony x75900e
2 Mediasonic 4 bay hard drive enclosures and 1 8TB Seagate external

How are the disks formatted?


I think that’s your problem.

So the Vero 4k doesn’t support NTFS formatted drives?
Reformatting 9 hard drives worth of media is not a feasible solution.
If this unit doesn’t support NTFS drives, then I’m speechless and have to go spend more money on a new media box/htpc.

NTFS is supported; but it has to run through user-space, so there’s a lot of overhead. This is the same for any Linux based device.

We recommend using exFAT or ext4 where possible.
See NTFS-3G - Wikipedia

I believe a kernel module for NTFS is in progress; so performance will improve in the future.