Install failed: can't mount root

Hi All,

I tried a lot of way that still remain in this error. Please check my hardware details.

Rapberry Pi2 B model (with 2amp power adapter, 24 inches HDMI support monitor, wireless mouse + keyboard)
Micro SD Class 10 32GB
Micro SD Class 4 16GB
Micro SD Class 4 8 GB

Thanks in advanced.

Hi,

After a failed install please put the SD card back in your PC and locate the install log file and paste its contents to:

http://paste.osmc.io/

Hi,

There is no install log file on my sd. I just saw cmdline.txt. Plese check it.

dwc_otg.fiq_fix_enable=1 sdhci-bcm2708.sync_after_dma=0 dwc_otg.lpm_enable=0 console=tty1 root=/dev/ram0 quiet init=/init loglevel=2 osmcdev=rbp2

cmdline.txt looks fine.

Have you definitely downloaded RC3 and not an earlier release ?

Are you saying you have tried 3 different SD cards and the install failed the same way on all of them ?

I downloaded RC3 that file name in my computer is “OSMC_TGT_rbp2_20150519.img” and file size is 256MB. I have tested with 3 different SD cards and 2 type of installer (a) OSMC Window Installer (b) Win32diskimager. Power connect to Raspberry Pi2 then it is appear OSMC screen - (1) Formatting (2) Install Failed: can’t mount root.

Where did you download the image from, was it here ?

https://osmc.tv/download/images/

Or did you let the installer automatically download the image for you ?

The file you have downloaded is corrupted - none of the images are as big as 256MB, as you can clearly see here the image is 154MB:

http://46.37.189.135/osmc/download/installers/diskimages/

So I have no idea what you have downloaded or from where, but you definitely do not have the correct file.

having same issue… Tried MAC utility as well as downloading the image and trying to run it copy pasting the image content directly to SD card…

Have tried both RC2 and RC3. Same issue exists…

Have Strontium 16GB Class 10 SD Card

Other things run fine on the same SD cards

This will not work. You must use something like Win32DiskImager or dd from command line to image the card.

anything for MAC

My Install.log

Thu Jan 1 00:00:09 1970 Starting OSMC installer
Thu Jan 1 00:00:17 1970 Detecting device we are running on
Thu Jan 1 00:00:17 1970 Mounting boot filesystem
Thu Jan 1 00:00:17 1970 Trying to mount to MNT_BOOT (/mnt/boot
Thu Jan 1 00:00:17 1970 Using device.boot: /dev/mmcblk0p1 and FS: vfat
Thu Jan 1 00:00:17 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:17 1970 Found a definition for storage: usb
Thu Jan 1 00:01:25 1970 Creating root partition
Thu Jan 1 00:01:26 1970 From a root partition of /dev/sda1, I have deduced a base device of /dev/sda
Thu Jan 1 00:01:26 1970 Must mklabel as root fs is on another device
Thu Jan 1 00:01:26 1970 Going to mklabel with device: /dev/sda with a label type of MSDOS
Thu Jan 1 00:01:27 1970 Calling mkpart for device: /dev/sda and fs: ext4 with start 4096s and end 100%
Thu Jan 1 00:01:28 1970 Calling fmtpart for partition /dev/sda1 and fstype ext4
Thu Jan 1 00:01:28 1970
Thu Jan 1 00:01:28 1970 Mounting root
Thu Jan 1 00:01:28 1970 Trying to mount to MNT_ROOT (/mnt/root
Thu Jan 1 00:01:28 1970 Using device.root: /dev/sda1
Thu Jan 1 00:01:28 1970 Error occured trying to mount root of /dev/sda1
Thu Jan 1 00:01:28 1970 Halting Install. Error message was: can’t mount root

You seem to be choosing a USB install but make no mention of using a USB thumb drive - have you tried just doing an SD only install ?

My MAC SD card reader is no working so was using an USB SD Card adapter to install.

Anyway finally Installed OSMC using Noobs installer… :smiley: Looks great. Nice job.

USB install doesn’t mean that you are using a USB to SD adaptor.

A USB install (selected in the installer) means that you want to boot the system off a USB thumb drive. (You still need an SD card inserted too)