Install Failed: Unsupported Device PI2 over NFS

Trying to install RC on Pi2 over NFS to my QNAP
I’ve tried multiple times on two different Pi2s
Overtime the installer reads Install Failed: Unsupported Device
After a time the error message changes to Install Failed: Can’t find root

Any suggestions on what I might be doing wrong?

I ran it again, and still received the Install Failed error, however it proceeded through the install process. I could see my NFS share populate with the system and after it finished it said OSMC INstalled successfully

It then rebooted and the reboot would not boot in to the system, the final line on screen reads:
end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block (2,0)

So if I install it manually as a Wired Connection and then “Configure Network Manually”
Enter in the details:
ip: 172:_16:__1:145
mask: 255:255:255:__0
gw: 172:_16:__1:__1
dns1: 172:_16:__1:__1
dns2: __8:__8:__8:__8

I still get the errors, but it installs and boots into Kodi and looks good


Even tho it is connected to the network, and running over NFS the network is not working.
If I go into network settings it shows as “Connection Failed”

I insert a USB wireless dongle. It reads it, I’m able to select my network, enter password and still: “Connection Failed”

Any help would be awesome!!

Also if this helps the NFS share is on a QNAP TS-412



There are a few issues we are aware of with NFS installs in the RC which have been fixed in internal builds and should be ready by final release.

“Install Failed: Unsupported Device” - this error is harmless. (but shouldn’t be there of course)

DHCP NFS installs in RC have a known problem where cmdline.txt has ip=dhcp:: after install - if you remove the double colon it should boot ok. (Static IP install should be ok) Also all NFS installs don’t leave a space between the word quiet and osmcdev in cmdline.txt - edit the line to include a space there.

Network IS working, otherwise your NFS boot would have failed. :wink: What is not working is the networking settings addon is not currently able to report or edit the network settings on an NFS install, but this will be fixed. You should have full network and internet connectivity if your network settings are correct.

We have networking set up so that only one network interface can be active at once to keep things simple. This means if you’re doing an NFS boot over Ethernet you won’t be able to use Wifi at the same time. This may change at some point in the future.

editing cmdline.txt did the trick!! thank you very much!!

I can also confirm that the Network is working. I should have just checked first. It said it wasn’t and I had a issue with that before so i assumed.

Also on the wifi, thats no problem. I have no need for wifi, I was just trying to get it working.

So bottom line I’m all good and this is awesome!!!

As usual you guys kick ass and I can’t thank you enough!