Install problem with monitor

@mk01 Thanks for that.
I already thought of saving the file and using it - as I have previously done with raspbmc.
Can you expound the means of saving the edid file, and then using it - the tvservice doesn’t seem to exist. Perhaps /sys/devices/soc0/soc/20e0000.hdmi_video/edid is the file I need to save?

That is indeed the file you need to save, but there is currently no support to use such an EDID at bootup yet.


I’m content to wait until it happens.


the file will be in binary form (so the one by default tvservice provides).
but that is no problem - the Veros edid can be converted.

I tried copying the bunary file from the Vero to a Pi, and using edidparser - but that told me it was malformed. Could I have improved on that ?


printf “$(echo \0$(find /sys -name edid -exec cat {} +|sed ‘s/\0x/\x/g’) | sed ‘s/\ //g’ | sed ‘s/\0//’ )” |tr -d ’ ’ > file_edid

it will create “file_edid” which should be parseable.

tried that and got

HDMI: bad EDID header 78 30 30 78 46 46 78 46

But I may not have set things correctly to perform the test.


a “” got lost somewhere, so once again

printf "$(echo \0$(find /sys -name edid -exec cat {} +|sed 's/\0x/\\x/g') | sed 's/\ //g' | sed 's/\0//' )" |tr -d ' ' > file_edid


Right - that did it, thanks