Installed April Update, now got a new update pushed, did I miss something?

I just got a message that there is another update available for my Vero 4K, but I haven’t read an announcement about such a thing and already have the April update. Is this known, if so, what is the changelog?

There was a fix for USB audio.

1 Like

I have just updated and now I have no audio! It just makes a slight thump noise when starting and stopping media.

I am not using USB audio, everything is passed over hdmi to my Panasonic amp.

Did you reboot after the update?

Only a soft reboot. Not pulled the power.

We’ll need to see logs then if we want to get any sort of understanding as to the cause of your issue.

After the reboot I tried Grey’s Anatomy, which thumped on the audio when starting but then did have sound.

I then tried a TV channel which made loads of thumps and then there was no audio.

Sorry I think its the old log you need 14:54:12.212 T:4075934288 NOTICE: special://profile/ is mapped to: special://ma -

Setting the audio from hdmi to PCM has the audio working again.

I tried switching back to hdmi while media was playing and I got a sad face and kodi restarted. I don’t know if that’s relevant to the issue.

I had similar issues with Greys anatomy only, like 6 months ago. Everything else worked fine, but Greys anatomy episodes was usually missing sound. When i stopped playing, started playing some movie for a few seconds (audio worked there) and after that same Greys anatomy episode again, audio worked.

I can’t say if it is the same issue, since I haven’t had that issue for few months (maybe 6-10 months).

Please enable debug logging and use the built-in log uploader.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.


Apologies for the delay in responding, family life got in the way!

I have recreated the issue and requested logs are here:

There are no GUI sounds throughout.
Started Greys Anatomy, several thumps on speakers then sound then started for Grey’s
Stopped Greys, several thumps on speakers
Started a Live TV channel, several thumps on speakers and no sound starts

I look forward to your response.



Just to add. The issue is present on all live TV channels, TV shows or movies. It’s not tied to one episode of greys. That was only the example I used.

I also have this issue… my music library will now not play after this update. I too have lost GUI sounds, and get loud pops through my speakers when starting my Vero 4K box and when starting or ending a movie/TV show… it feels like something clearly got broken during the USB sound patch???
My system is now unusable, loud popping sounds and no music library. Please don’t ask me for “logs”, and have no idea how to do that, and didn’t really buy the Vero 4K box to become a sysops person… just need it fixed…

OK. Looking into it, but we may have to come back to you - only 2-3 ppl have reported this

Oh… I spent £100 on the Vero 4K, happy to send the box back.

Not sure how that comment is helpful.

They have said they will look into the issue so give them a chance.

The reply seemed quite dismissive… “may have to come back to you - only 2-3 ppl have reported this…” He could of said something like “Thanks… we are looking into get, stay tuned…”

All I’m saying is you may have a unique problem for which we may need logs. Sit tight. Did you try toggling to hdmi and pcm?

Well for me

was quite dismissive, especially when requests for logs and clear information on how to provide them are on almost every thread in Help and Support section. One of them is literally two posts above yours.