Installer fails to mount sd-card

I use the installer on ubuntu, and during installation the software fails with an mount failed error and exits.
the last lines of the log.txt:

Mo. Aug 10 18:36:05 2015 Running partprobe to inform operating system about partition table changes
Mo. Aug 10 18:36:07 2015 Mounting /dev/mmcblk0p1 to /tmp/osmc_mnt
Mo. Aug 10 18:36:07 2015 Could not mount filesystem!

I can mount it by hand without problems. Any Ideas what fails here?

Are you running as sudo? The installer must have root privileges to write a disk.

Please upload the full log

Which version?

I would also recommend rebooting and removing other USB devices


yes, I did - same error

there is the full log: log.txt · GitHub

I am running Ubuntu 15.04 (vivid) with Gnome 3.14.1 or awesomewm

I will retry without the external disks attached.

removed the USB-disks, I did not reboot. that is simply not done in my opinion.

Do. Aug 13 16:13:24 2015 Can't open /sys/block/ mapper/removable

Looks like you had XBian on the SD. I am not sure how it formats it but I would recommend you zero the MBR first: dd if=/dev/zero of=/dev/mmcblk0 bs=512 count=1 and see if this helps.

You say you can mount it by hand. My guess is after partprobe operation something else is mounting it (automounter, perhaps), so OSMC can’t.

Can you elaborate?


so, retried with zeroed SD-card and even after a fresh reboot. (to answer your question: reboots do not find and eliminate a problem, they just work around it, so it is in my opinion the lazy way to solve a problem, without really solving it.)
the current log can be found here: log.txt · GitHub
the partition created on the sd-card is visible to me, but seems not to be mounted, if it gets mounted for a short period of time, I couldn’t see that happening.

Agreed, but it gives some indication if it is the issue. We can then look at what a reboot brings to the table that the current method does not…

Your log is not providing much info, except missing syfs which is… interesting, but not an issue.

What I’d like to know is:

  • is /tmp writable?
  • is /tmp/osmc_mnt being created?
  • can you manually mount to /tmp/osmc_mnt


I had the same issue on Ubuntu 15.04 and Windows 7, both 64bit and searched for hours!
Then I plugged my Transcend TS-RDF8K USB 3.0 card reader into a USB 2.0 port of my Asus P8Z68-V mainboard and everything worked!
I have the newest TS26 firmware for the cardreader and no idea what causes it under both OSes.
Maybe a USB command the USB 3.0 Asmedia chipset doesn’t support?

Hi I had the same issue.
Solved by turning off automount for desktop
I noticed that when the installer trying to umount - mount sd card partition, nautilus has automatically mount the partition
gsettings set automount false

HI, I have the same issue, OSMC could’n mount /dev/sdb during installation, I use ubuntu gnome 15.10, turning off automount didn’t help, i try with sd-card and usb stick, can anybody help me with this ? Maybe there is a way to copy img to usb by my self without osmc-installer ?

[SOLVED] Linux Mint Live CD made it without any problem :slight_smile: