Installer not working for RP3

Installed osmc to sd card on mac. When booting pi 3 just get coloured square in centre of screen.
Tried sd card from RP2. Osmc loaded and could navigate and play videos but tvheadend not working and no connection to network and nowhere to set one up.
About to try install via noobs…

1 Like

Use the latest image from the OSMC website.

NOOBS won’t work, as the image has not been updated yet.


I got the installer to grab the latest image. Should that not have worked?
Tested noobs to make sure sd card was ok.

I have the exact same issue and would like to know how to fix this.

When installing I could not chose Pi 3, so I chose pi2. I hope that’s ok?

Guys, I know the geekiness in you is strong and you are very eager to get all rpi3’d up n shizzle.

Just bear with us.
The device has only been available for a couple of days.

You all know how important testing is, and you all know how angry you would be if we pushed out OSMC with making sure it wouldn’t rip a hole in time and space.

Who wants to be dealing with that drama… :smiley:

A fully functioning OSMC RPi3 release will be available soon, we just need to smooth out a few niggles.