Installing Transmission on Pi 2 running Alpha 4

Just installed alpha 4 on Pi 2, no problems, works great.
From the program list, installed Transmission but this appears to be just the front end which is the same as Kodi.
On Openelec, you had to add an unsupported repository and dig through the system systems to find the main install. There does not appear to be a similar method to install Transmission on OSMC.

Howe do you install Transmission (if it is supported) ?

Thanks in Advance

It’s a full Debian OS so it’s likely in APT already. You can of course build your own version from source.

We will ship Deluge in our application store

Thanks for the quick response Sam,

SSH’d in and used:-
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install transmission-gtk
sudo apt-get install transmission-daemon

took a while but all installed okay.


opened through OSMC -> Programs -> Transmission -> Error “could not connect to Transmission”
This is the same initial error as occurred with Openelec.

Went back in and:-
sudo apt-get install transmission

reboot’ed, same error.

Any ideas ?
Otherwise I’ll wait for the Deluge version.

1 Like

You might need to configure the rpc username and password… What config is transmission running currently? (I have a feeling the Debian pkg enables rpc auth but didn’t set the credentials)

Evening, I’ve had transmission working perfectly on RaspBMC but I got a pi2 and wanted to put it back on. I followed the walk through above and a walk through of the user permissions but when I go to restart the daemon it doesn’t work and throws an error… I’ll try and get the error message.

Any ideas?

Which walkthrough did you use to set up the right user permissions? I’m having some issues with Permission Denied messages.
What error are you receiving?

Any updates on this?


I Also have The same issue. “Could not connect to transmission”.
I Tried With the Username and password Of My router account, i installed the daemon using ssh but i really don’t know what to do…

Hi boys, i have transmission working perfect with my Raspberry Pi2 and OSMC.
Im folow this instructions, and works fine.

Please paste your settings.json file. and /etc/group

Maybe I can help.

Sorry for my language im speak spanish.



Can you copy your line from group for transmission premision?

I followed guide from your link, but no luck, still "permission denied.
Just to mention, my download path is on external ntfs hdd.


Evening all,

I’ve had a success which I thought I’d tell you about. I was getting the permission denied errors so slightly changed the install process so I could login in to the client. Then I got the torrent stopping after a few Meg issue…

The solution was to mount the USB drive in the /mnt/ folder rather than it being in the /media/ folder.

Just downloading my first test and it’s at 400+mb and counting!!

Hope this helps,