Internet connection dropping out

Hi, I had this same problem in February. The internet connection keeps cycling through;
Busy, Not connected check network settings, Connected. Then it starts over ad nauseum.
When this occurred before it mysteriously cleared after a couple of days. It appears to be more persistent this time.
I have read through several similar posts but none of the suggestions have made any difference.
I have a hard wired Raspberry Pi 2 running the latest version of OSMC running Kodi 16.
All connections appear to be fine.
Any suggestions please.

Here are the log files
https://paste.osmc.io/ebakipoyex

On the one hand you seem to underclock your Pi. Did you do that on purpose? Did you choose the normal/default profile in MyOSMC Overclocking?

On the other hand you have installed several repositories that are known to be invasive and therefore can impact several parts of the system including the network.
Suggest for a test you rename your .kodi folder and reboot. If your internet works fine afterwards than you know that something you installed is the culprit.

Are you actually experiencing an internet connectivity problem from your Pi though, or are you just going by the Network summary page in Kodi ? (Which is not particularly reliable)

I am actually having connection problems. If I can get a video started it will pause, buffer then pause again and then dropout. This occurs as the busy, not connected cycle begins.
Network settings in My OSMC shows as connected, which I know is no real proof, but in Confluence network settings show the on/off cycle.

Hi, I don’t remember changing the Overclocking settings! Possibly an age related problem…
How do I go about changing the .kodi folder?

If that does make a difference do I need to delete repositories and how do I find out which are likely to be causing the problem?

Thanks for the fast reply

SSH into OSMC and do mv .kodi .kodi_backup

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

If you leave another computer pinging your Pi, do you see timeouts when the problem occurs ?

Yes I tried this earlier.

If your Ethernet interface is intermittently dropping out (such that you can’t even ping it continuously from another lan device) then it will be a power related issue. I can see your Ethernet link is dropping here:

Mar 21 11:08:58 osmc kernel: smsc95xx 1-1.1:1.0 eth0: link down
Mar 21 11:09:03 osmc kernel: smsc95xx 1-1.1:1.0 eth0: link down

There are other obvious signs of the Ethernet connection dropping and reconnecting in the log. Check your power adaptor and/or try a different one.

Also if you have any USB devices connected, try running for a little while with them disconnected. Excessive power drain via the USB ports can cause the same issue.

Well, I have renamed the .kodi folder as suggested by fzinken, swapped to another power source and no change at all other than I cannot see the addons that were installed.

Tried a different ethernet cable and/or plugging into a different switch ?

Your problem is of a hardware nature, you’re not going to find a software solution for it.

Just move the folder back mv .kodi_backup .kodi

I have downloaded OSMC for my old RPi 1 and the problem still exists so, hopefully, that points to the ethernet cable. I will get a new one tomorrow and find out. The router appears to be okay as my iMac has no problems with its internet connection.

Thanks, that was what I thought I would need to do.

I have connected with a new network cable and no change. I have tried each of the ports on the router and no change. Rang my ISP and asked them to check the internet connection, no change.
I am going to set up OSMC without anything else, repos etc and see if the problem still exists. If not then I will assume that it’s something that I’ve added.

I have put an old SD card in with xbmc 13.1 on and there was no problem with the constant drop outs that I have been suffering! I assume that proves that there is no hardware problems and that there is something in the software, no doubt imported, that is causing the problem. If anyone has any ideas of how to track that down I would be very happy for any suggestions.

Hi @baker1,
I think I got your same problem. Did you manage to resolve it at the end?
Thanks.

Hi Githeo,

Yes after going through all the reasonably cheap options of replacing the ethernet cable and power supply it turned out to be a router problem. Since replacing the router the problem does not exist.
Good luck with yours, I understand just how frustrating it is.

Thanks @baker1!

My router is the ISP box, thus changing it is not an option although I know that this box is not the top!

Anyway I don’t understand where is the problem since, everything works on the command line on osmc but not from the GUI.

We needs logs How to submit a useful support request - General - OSMC and a full description of your problem.