IR keys repeated when Kodi is running and LG TV connected

#21

Try editing /lib/systemd/system/eventlircd.service.

Change:

ExecStart = /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd --repeat-filter --release=_UP -f

to:

ExecStart = /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd

#22

Hi Sam,

I’ve changed the systemd (I kept the -f flag) file and rebooted. The result is the same as with the repeat filter on and release setting: IR keys are repeated many times:

6c 0 KEY_DOWN linux-input-layer
6c 1 KEY_DOWN linux-input-layer
6c 2 KEY_DOWN linux-input-layer
6c 3 KEY_DOWN linux-input-layer
6c 4 KEY_DOWN linux-input-layer
6c 5 KEY_DOWN linux-input-layer
6c 6 KEY_DOWN linux-input-layer
6c 7 KEY_DOWN linux-input-layer
6c 8 KEY_DOWN linux-input-layer
6c 9 KEY_DOWN linux-input-layer
6c a KEY_DOWN linux-input-layer
6c b KEY_DOWN linux-input-layer
6c c KEY_DOWN linux-input-layer
6c d KEY_DOWN linux-input-layer
6c e KEY_DOWN linux-input-layer
6c f KEY_DOWN linux-input-layer
6c 10 KEY_DOWN linux-input-layer
6c 11 KEY_DOWN linux-input-layer
6c 12 KEY_DOWN linux-input-layer
6c 13 KEY_DOWN linux-input-layer
6c 14 KEY_DOWN linux-input-layer
6c 15 KEY_DOWN linux-input-layer
6c 16 KEY_DOWN linux-input-layer
6c 17 KEY_DOWN linux-input-layer
6c 18 KEY_DOWN linux-input-layer
[…]

At the bottom, there no _UP key anymore, as expected.

#23

I’m stumped.

There was a fix for eventlircd to stop Kodi grabbing events incorrectly which I’ve prepared for the next update. It may be tricky for you to test as the staging repository currently contains Kodi v18 builds.

Sam

#24

Hi Sam,

Do you refer to this commit: https://github.com/osmc/osmc/commit/3b3123cc6d39d5caebe074c4ca3a9a337eeaa560#diff-3fa35519df81cdeefc49c5958d8cf968 ?

I’ll try to diff dmesg for LG TV and work displays. I will also try nightly build.

Nick

#25

That’s the one.

#26

I tried that fix, but didnt help. Installed nightly build yesterday, but repeated keys are still present. When connected to display at work, everything works fine…

Sometimes the keys are repeated infinitely. Restarting Kodi stopped the “loop” immediately (messages in irw stopped)

I really want my (all-in-one) remote to work, because Kodi will be used as settop box for watching live tv. I dont want to go back to multiple remotes :sleepy:

Tonight I will test my newest Lirc remote config at the RPI to make sure it not causing problemens. Will also test IR behavior when Kodi is off, but system is under load.

Do you have other ideas about what might be causing the weird IR behavior when my LG TV is connected?

#27

Are any other devices connected to the TV?
Can you remove them (unplug HDMI) temporarily?

#28

Hi Sam,

Nothing else is connected to my TV.
lirc & eventlircd setup is exactly the same on both the Vero and RPI. Only difference is that RPI uses TSOP IR sensor, which is connected to GPIO pins.

I’ve swapped HDMI cable from Vero to RPI and the remote is working without issues at the RPI.

Nick

#29

Unfortunately I am out of ideas.
We could swap the hardware over – but I can’t think of why it would work well in one environment and not another.

Sam

#30

Hi Sam,

I discovered something very interesting. My IR remote works most of the time when I place the Vero on top of the dark Vero packaging. As soon as I place the Vero back on the wood of the TV cabinet, the issue returns.

When the Vero is placed on my black wooden center speaker, issue is present. When I place the packaging between the speaker and the Vero, issue is gone.

Weird…

#31

Can you take a photo of the living room setup?

#32

No problem. Let me know if you need additional photos.


#33

Not sure still unfortunately

#34

Ok thanks for checking. Never had IR issues with other devices and my all-in-one remote.

Can we swap the hardware? Let’s hope that fixes the issue.

Nick

#35

Sure, ping support@osmc.tv.

Sam

#36

Is that the Vero 4K IR extension in front of the speaker and behind the cable, or is that for another device (like the Pi)?

If so, have you tried unplugging the IR extension from the Vero? If not, have you tried using the IR extension for the Vero?
ZoomIn

#38

That’s the Vero IR extension. It’s not connected at the moment, because the Vero is currently in line of sight.

I’ve tested both internal IR receiver and the extender. When I tested the extender, I placed the Vero inside the TV cabinet with door closed and internal IR sensor masked with electrical tape. Issue is still present, but when I place the Vero on top op the packaging box, there’s an improvement. That’s very weird, because the IR light should not reach the internal sensor. I’ve double checked that the IR light cannot reach the internal sensor, by unplugging the IR extender.

#39

I’ve received a new Vero box from Sam and the issue is solved! :smiley: I’m not 100% certain if the new box solved the issue, or a new firmware update of my TV (TV was auto-updated before I received the new Vero).

Using the LIRC profile that was created with irrecord on a RPI3 IR performance was not optimal (had to press a button twice). I replaced it with the builtin Xbox 360 LIRC profile and applied the same profile to my all-in-one remote. Now IR response is great.

The only thing that’s not optimal is that some remote presses seem to be ignored when I’m controlling the Live TV OSD (video/audio settings, etc).

#40

I suspect the issue was resolved due to some changes we made in the May update with regards to remote support.

Sam

#41

Thanks for your reply Sam.

Good to read that OSMC is frequently updated. You could be right, my first Vero unit was not tested with the Leia May update (only Leia nightly).

Do you know a way to improve IR performance for the Live TV OSD? Are presses missed due to system load/disabled interrupts? I haven’t tested thoroughly, but didn’t experience missed remote presses when using the OSD for movies (DLNA streaming). I noticed that movies use AC3 bitstreaming and Live TV uses AC3 decoding (resulting in increase load?)

Nick