IR Signal only working when connected to a TV?

I have bought a TSOP7000 as IR-receiver for my Raspberry Pi to control my OSMC with my Beo4-remote.

The problem is, that the Beo4-remote is only able to control OSMC when connected to my TV. When I connect the Raspberry to my Projector the Beo4-remote is no longer able to control OSMC.

What is going wrong here, anyone with any suggests?

Could it actually be that your Beo4 actually send the IR to the TV and the TV via HDMI to OSMC and your TSOP7000 actually is not being working even if connected to the TV?

Most likely it is just working via CEC, not the TSOP.

I can guarantee that beo4 only works with Bang & Olufsen TVs normally, because of their high frequency 455 mhz.

This is why I had to buy a TSOP7000 which can receive those high frequencies.

Also the Beo4 remote works a split second after reboot, but then it stops to work. Something is wrong in the bootup script, when I change to the Projector. Maybe the projector is recognized as something else? Is the Raspberry received any information from the device connected to the HDMI port? Would I be able to compare what the Pi receives from the LG TV and from the projector?

Well nobody is objecting that. The question we had is if when connect to the TV the Beo4 controls the Pi via the TSOP or via CEC. So to first exclude that as the possibility I suggest you disable CEC when the Pi is connected to the TV and see if you still can controll the Pi via the Beo4.
Just be sure you have SSH access so you can revert back if you can not controll via Beo4 anymore.

Hi, thanks for taking your time…

Taking off “SIMPLINK” as LG calls it doesn’t change anything. The Beo4 remote still works fine with the tv - and the normal LG tv remote of course doesn’t, when SIMPLINK is switched off.

This conclude, that the TSOP works fine. The problem appears when I switch the HDMI cables, so OSMC is showed on the projector.

I agree on that topic, still worth to test especially as there should be no influence on what you connect to HDMI on the LIRC reception.
So unfortunately I don’t have any further suggestions.

Dammit :frowning: Then I must just do some trial and error - else I might just stick to the Kodi App in AppStore… Would just be nice to control everything with one remote, light, sound and Raspberry…

So I have tried to test with “irw” in terminal. I can get a few signals and then it stops to work again.

It is weird because there is no problems when the raspberry is hooked up to the tv…?

Well a little update… The receiver will receive the signal if I click multiple times on the button (on the projector). It is weird, because it works smoothly, when in the TV.

Still no ideas fzinken? :slight_smile:

Well I still would not see a relation to the HDMI connection. But I am no expert on LIRC. So just wait maybe someone else will have an idea.

How is the room set up? Is it possible that the projector (Very bright light) is shining on the Pi and thus the Pi is not able to see the remote (very dim light)?

Hi jb2cool, thanks for writing. No this is not a possibility. I’ve tried multiple options:

  1. The Raspberry connected to my TV, while my projector pointing directly on the TSOP-chip. Result = The Beo4 remote works perfectly on the TV.
  2. Changing the HDMI cable to a shorter one (1 meter) - Makes no difference.
  3. Tried with irw, viewing if the Pi actually receives any signals from the Beo4 remote when connected to the projector. Result = Yes it receives signals, but only when I press multiple times fast on the button. Fx. if I want to navigate “Up” in OSMC, then I’ve to push the up button 4 times fast, sometimes it works, sometimes it doesn’t.

Not sure if I just have to accept that it only can work with the Kodi App from App Store. Would be great to control both the TV and the Projector with my Beo4 Remote…

  • Sounds like bad signal.
  • Make sure you wired the TSOP properly (with GND)
  • Use TSOP4838 if possible. We used that for the first OSMC remote for Raspberry Pi and didn’t have any complaints with sensitivity.

Ultimately you need irw to pick up the presses properly.
I suspect you won’t have one at hand, but to diagnose I would scope the TSOP in a room where it works and in a room where it doesn’t and compare.

Hi Sam,

But it works like a charm when it’s connected to the TV? Also when I run irw.

I assume that:

  • TV and projector are in different rooms
  • projector is connected with different cables and peripherals

Perhaps it’s a shielding issue, but really hard to work this one out without knowing more about your environment.


It’s all in the same room.

TV is hanging on the wall with the raspberry behind it. TSOP is able to either stay behind the tv or hang out, so it’s possible to have a great connection without having to send signals through the tv.

The projector only have 2 cables - power cable and hdmi to mini hdmi cable.

I don’t see why this makes any problems. HDMI shouldn’t make any difference between a TV as a monitor or the Projector as a monitor… :frowning:

If the cables aren’t shielded properly it could cause problems.

You should have enough to go on to start ruling things out

But I don’t understand why “cables aren’t shielded properly” should make it work perfectly with the TV connected but not with the projector connected?

Also the cables to the TSOP is a thick cable with great isolation… I really don’t think it’s the wires but something else that may disturb the raspberry.

Doesn’t there exist any files containing info on the inputs from the HDMI output?

Unfortunately I have no further solutions.
I’d likely need to be in the room to see what the issue may be. All I can suggest is interchanging some peripherals and if you have a friend with good technical knowledge around to get them to take a look.

I’d also definitely rule out CEC as being the reason it works on the TV. If you load cec-client (with Kodi stopped) and pressing remote shows output, then it’s actually your TV doing the heavy lifting and perhaps IR was always problematic.