Is it possible that braking TV's HDMI port also broke RPI3's HDMI port?


my TV has 4 HDMI ports, on HDMI 3, RPI3 were connected.
This HDMI 3 port doesn’t work anymore (I tried several devices/hdmi cables), and RPI3’s HDMI output doesn’t work anymore.
Is it possible that braking TV’s HDMI port also broke RPI3’s HDMI port?
RPI3 works, I cann ssh it, but there is no video output on its HDMI port.
I don’t have composite cable in order to check composite output.

Has anyone here had such an experience?
Can it be repaired somehow or I should buy new RPI?


I suggest, you shutdown the Pi3 via ssh, power off and give it a new SD-card with a fresh installed OSMC, see Download - OSMC.
Also, try one of the other TV’s HDMI ports you know they are still working. By that you can decide whether the Pi3 is broken or just some issue with the OSMC software stack on the old SD-card.

I tried different HDMI ports as well as monitor instead of TV, but I can’t get output from the RPI3 whatever I do. As I cannot get output on TV’s HDMI 3 port from any of devices, I concluded that this port has gone for good.

On the same setup output from the RPI2 works, but not from RPI3.

I don’t see how new SD installation would help.
Looks like it is time to buy a new RPI3 device.