Is there any stand-alone command for calibrating the gui size in Raspberry Pi 3?

#1

Hello everybody.

I want to adjust the size of the GUI in OSMC because even if I set it up on the video calibration option in the system settings area it doesn’t stick between reboots.

As a workaround I would like to create an automatism with systemd or with crontab task for doing this after OSMC loads.

Can this be done somehow from any built-in function from a crontab task?

Thank you very much.

#2

First question would be why would you need overscan changes? Put TV on Just Scan / 1:1

#3

Hi.

Thank you for your answer and question.

Currently I am using OSMC on two setups.

The first and most used one, is the one that demands video calibration everytime I reboot or just plainly powerdown or exit (both at the power menu).

The other one doesn’t present these issues, but then again that one is not connected to a standard old CRT television with PAL 4:3 layout, like this troubled one.

I can’t even configure that 1:1 setting that you mention. (Could it be) Because I don’t even know the whereabouts of its remote control, (where I could, perhaps, use it to unlock and access more advanced settings inside the TV device menu), and besides, when I try to access the setup option from the standard 6 keys that are at its footer panel, on the menu I get ‘Not available’ displayed as an answer.

Perhaps the TV set is locked…

But maybe this is not that important.

What indeed matters is that, previously, with other versions of OSMC, I could do that video calibration and the setting would stick throughout reboots/powerdowns/exits in the power menu…

Hope I managed to answer your question.

Thanks

#4

If the settings are not sticking after issuing the exit command from the power menu, this could be an indication that your sdcard has issues and is operating in read only mode.

Calibration settings should be stored in guisettings.xml otherwise.

#5

@ActionA

Thank you for your point.

But current set up is laying on an external HDD, (root and home partitions are there. Except boot).

But last weekend I’ve tried with a new setup on a clean install to an sdcard and the result was similar. Video calibration settings wouldn’t hold as well…

Thanks again.

P.s.: I noticed as well that guisettings.xml seems to have an erratic behavior in the sense that even if I change some of its settings with mediacenter.service stopped, when the mediacenter.service starts again, they seem to regress to a previous state.

Perhaps there is something wrong with the filesystem. Do you suggest anything?

Thank you.

#6

Are you using the latest version of Kodi (i.e.v18)?
The Pi also supports config.txt for setting overscan settings – but if possible, it’s always best to avoid overscan.

#7

Hi, yes I’m using latest stable. And changing config.txt either from my OSMC or command editor doesn’t change but the terminal framebuffer, doesn’t affect Kodi GUI.

Thank you.

#8

Supposedly this was resolved, but I’m not so sure:

#9

Yes I did skim through that post as well.

I tried some of its approaches but I guess I should “upvote” there as well for reopening that status.

Thank you.