Issue fast forwarding on OSMC 17.1


I’m a newbie so please forgive my lack of wisdom using OSMC / Kodi. I have a HDD drive with 3D movie rips (full rip - MKV) attached directly to my Raspberry Pi 3 running OSMC. On the previous OSMC build I was able to fast forward and rewind without any issues. However, since I’ve updated the OSMC build to the newest version (17.1) this morning, I am having issues with fast forwarding and rewinding the 3D MKV files. When I fast forward a 3D MKV file, it moves to the desired location in the movie and the play timer is moving but the video just hangs there?

Full bluray rips to m2ts files fast forward with no issues. Any suggestions on whats going on or any settings I need to change?

Can you not simply use the incremental skip ahead with the arrow keys? Isn’t this why we got rid of VHS?

I use a mouse…I point the “pointer” to where I want it to skip and the the movie resumed flawlessy before update. I also tried with a remote by pressing the arrow key at 2X, 4X, 8X and 16X; doesnt matter the speed, once I hit play again it just hangs.

Not the fast forward >> arrow key. The right key on the up, down, left, right, or d-pad. I probably should not have called it “arrow key” in my previous post. :wink:

I’ve tried the D-pad on my remote. I press right and it “seeks”, then I try to resume playback and the video just hangs while the video timer keeps moving like the video is playing but it’s not.

What remote?

For clarity…I just tried a remote, I primarily use a mouse with my rasbperry pi 3. I can start a movie with bluray m2ts rip and using the mouse, skip all the way to the end and resume movie perfectly. I can also rewind perfectly, from end to beginning. Only the 3D MKV rips don’t work.

Are the files local or on network storage? Wired or wireless?

Files are local, HDD is attached directly to the raspberry pi 3. Connection is wired; I just want to watch the action scenes sometimes in the 3D movies so it’s a headache right now becaue I don’t want to watch the entirety of the movie to get to the good parts.

Can you not point and click at the progress bar with your mouse?

Thats what I’m doing…I point at the progress bar on a 3D MKV movie and it goes directly to the location I want it to go. I can see the scene but the vieo just hangs but the play timer moves forward like the movie is playing but it’s not. No audio, no nothing. I’ve tried all my 3D MKV videos and they all behave the same way.

i.e. I’ll start Transformers-Age of Extinction and want to see the Optimus Prime and Lockdown fight. Point the mouse at the progress bar and select “click” to where the scene is. However, it just shows Lockdown in a scene or whatever and the movie just hangs.

I’ve tried pausing the movie and hitting play again…no luck. Worked great before update though.

Ok, then next step is to turn on debug logging, reboot, demonstrate the issue, then upload debug logs and provide the link here.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

In your report, please let us know:

The issue you are currently experiencing with OSMC: Fast forwarding on 3D MKV movies not working.
What you were doing when this issue occurred: Updated to OSMC 17.1
Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue: Fast foward on a full 3D movie rip (MKV)
The device you are currently running OSMC on: Raspberry pi 3
What peripherals are attached to the device?: five HDD devices, all behave fine
Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?: Issue started when I upated OSMC build to 17.1

OSMC Log Uploader states: URL:

Hope i did everything correctly. Thanks a bunch for your help.

As a test, is the issue still present if you remove 4 of the attached HDD?

Yes…I unplugged all HDD devices except for the HDD with the 3D movies. Rebooted and still same issue.

This is a pi3?


You know that you are underclocking this pi? Did you set Turbo in MyOSMC overclock settings? You should set that back to normal. MyOSMC has not be optimized to handle Pi3 overclocks yet.

Set to normal…thanks for advice.

To confirm, you should now see arm_freq=1200 in your logs. Not sure if it will make a difference with your issue though. Can you try Settings>Player>Disable adjust refresh rate?

Otherwise, I’m going to defer to @popcornmix, maybe he has an answer to this issue.

Under normal…arm frequency is at 900. I disabled adjust refresh rate and auto sync to display. Still does not fix the issue.