It is not possible to connect to the Internet via both cable and Wi-Fi

#1

I can’t connect to the internet both via cable and via Wi-Fi just writes that it connected but without internet it says: “eth0 (no internet)” please help

0 Likes

#2

have you tired restarting your router?

0 Likes

#3

I’ll try that restart but I tried another cable so we’ll see.

0 Likes

#4

restart did not help still writes: eth0 (no internet)

0 Likes

#5

are you able to ssh in? details can found here:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.

0 Likes

#6

Yes

0 Likes

#7

0 Likes

#8

you want this http://paste.osmc.tv/iwowesereb

0 Likes

#9

Hi,

Please provide the output of the following:

ping -c 4 8.8.8.8

&

ping -c 4 google.com

Thanks Tom.

0 Likes

#10

both were successful

0 Likes

#13

Hi,

Ok that confirms the errors in MyOsmc are false positive. Please try disconnecting the cable and connecting to wifi and complete the same ping tests and post the results here.

Thanks Tom.

0 Likes

#17

0 Likes

#18

0 Likes

#19

Wired

0 Likes

#20

Hi,

So wifi ping tests look ok aswell, but Dilthedog did notice an issue with; in that it keeps dropping out.

On wired are you directly connected to router, or is there a switch involved or a powerline adaptor?

If directly connected, try a different port on the router.

Tom.

0 Likes

#21

I’m connected via a switch and I tried another port and directly into the modem and still the same but this one was already working so I don’t know why it doesn’t work.

0 Likes

#22

Hi,

Whats the make of the router & the switch?

Also could you please provide new logs, for when directly connected to the router.

Thanks Tom.

0 Likes

#23

If you can ping 8.8.8.8, then it isn’t an internet problem. Most likely is it a DNS issue. To end-users, DNS issues look like the internet is broke, when it isn’t. Just all the phone-book lookups don’t work.

I don’t know much about OSMC-specific networking, but on debian/Ubuntu systems, there are a few rules.

Do not enable both wifi and wired connections at the same time. Enable 1 or the other.

Normally, I’d ask to see the output from
ifconfig -a
route -n
when troubleshooting issues like this.

Never assume that any specific hardware is perfectly working. Swap the cable, try different computers in the same router and switch ports, notice if they have similar issues. If the pi is getting network setup from DHCP, try doing it with all static data for the IP, netmask, gateway and DNS settings.

If you haven’t patched the router in the last 2-3 months, then look for firmware updates. Good routers have patches every month. Routers that haven’t been patched in over a year need to be replaced if there aren’t any new firmware available or you don’t switch to a current release of dd-wrt/openwrt/tomato or some other after-market firmware that maintains support with monthly patches.

IMHO.

0 Likes

#24

Just so we don’t get side-tracked, the OP has already demonstrated that it’s possible to ping both 8.8.8.8 and google.com. The log also shows that wired is repeatedly connecting and then disconnecting – and so is wireless.

0 Likes

#25

Then I’d get a new microSD, load a fresh, untouched, OSMC OS, run that for a little bit to see if the wired network issue goes away. If it does, then the SD was failing.

If the issue continues after changing the SD storage, then it is hardware, somewhere, as mentioned above.

I would completely ignore wifi, but I completely ignore wifi all the time. Wifi networking has so many issues that I’ve seen in doing thousands of deployments, that I avoid it whenever possible.

0 Likes