Item Text Missing after November Update

After updating to the November Update on my Raspberry Pi 3, some menu text is missing on OSMC and Live TV, and the font is strange, applying the default font works but after a reboot or system shut down the font and text on those 2 menu items is lost again.

The logs are here

I’m not sure if this going to be related but you will want to do it anyway. Go into the My OSMC add-on>PI Config>Display> and set “hdmi_group” to “CEA” and “hdmi_mode” to “16”. Please let us know if this fixes the issue or not.

It tried but the issue persists.

Is this only happening with the OSMC skin or is there issues if you switch to Estuary?

I tried the other two skins, and one is displaying text for OSMC and Live TV, but it’s missing the OSMC icon…

That’s expected, you’ll find it under program add-ons.

I’m not sure what is going on here but I think the next thing to try is to reset your skin settings and see if that cures the issue.

I tried that as well, still it won’t survive a reboot.

Could it be that your SD card failed (RO mode)?
Try to copy a file to the SD Card and see if it survive a reboot.

Maybe try SSH or local terminal and…

systemctl stop mediacenter
rm -r ~/.kodi/userdata/addon_data/skin.osmc
rm -r ~/.kodi/userdata/addon_data/script.skinshortcuts
systemctl start mediacenter

(If you use the local terminal you don’t need the first command)

the command rm -r ~/.kodi/userdata/addon_data/script/.skinshortcuts is giving me an error that remove failed no such file or directory,

The top commands were able to reset the skin settings but the issue remained.

Edit: thats a typo there it’s rm -r ~/.kodi/userdata/addon_data/script.skinshortcuts

If that is exactly what you typed, it’s not correct. Re-read the post above for the correct command.

Disregard that second one. I was looking on my machine for settings files that might be relevant and i forgot to check your log to see if you were using that one, which your not. I’m at a bit of a loss on what is going on here other than if there was some corruption on the SD card like fzinken mentioned above. If you want to stick with the OSMC skin you might have to just do a backup and a fresh install. The only other thing that is coming to mind to try before that is to temporarily load a fresh profile and see if it still happens. I am curious to know if there is something in your user settings i’m missing that is causing this…

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

That’s a typo on this post.

Let me try and see how it goes.

1 Like

This worked, thanks:+1:

1 Like

Good to hear. I guess that mean there is something in your settings somewhere that was causing this then, I would assume something in the .kodi/userdata/addon_data/ folder, but i’m at a loss to which file it would be in.