January update now iqaudio dac not working?

yep works for me thanks all for the help :smiley:

I checked the OSMC config. The overlay was set to Hifiberry DAC. I changed it to Hifiberry DAC + and now it works.
I must have changed it whiole troubleshooting and didn’t notice the difference.

Thanks for the help

My IQaudIO Pi DAC Plus is no longer working too with January update. I tried changing settings and rebooting then changing them back. didn’t help.

log reports…

http://paste.osmc.io/yigikohumu

ok… sorted…

adding… dtparam=audio=off fixed it for now

Digi+ now back working with the dtparam fix, thanks for sorting so quickly and easily. Cant access Pi Config but not really a problem for me.

This indicated an issue with the format in config.txt. Please provide a debug log when you try to access PiConfig.

See also

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Fix didn’t work for me. It restored the entry in the settings menu. Selecting it gives a soft ‘pop’ from the speakers, but it’s impossible to get any other sound out of it.
Note: This is using the Hifiberry DAC+
I also noted I suddenly had two dtoverlay entries in my config.txt I removed the one that read dtoverlay=hifiberry-dacplus-overlay since it should be dtoverlay=hifiberry-dacplus
Note2: I also tested the option dtoverlay=hifiberry-dacplus-overlay just to be sure. But that doesn’t work either.
Note3: running speaker-test will always reply: Playback open error: -16,Device or resource busy
dmesg shows:
[ +0.080973] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ +0.000025] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ +0.021800] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ +0.000026] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
[ +0.045411] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ +0.000026] cdrom: Uniform CD-ROM driver Revision: 3.20
[ +0.001711] usbcore: registered new interface driver uas
[ +0.001847] snd-rpi-hifiberry-dacplus sound: ASoC: CODEC DAI pcm512x-hifi not registered
[ +0.000028] snd-rpi-hifiberry-dacplus sound: snd_soc_register_card() failed: -517
But aplay -l correctly shows:
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0

Adding dtparam=audio=off to /boot/config, rebooting and selecting IQaudIODAC Analog from Kodi settings freezes my system instantly. If the DAC is selected before reboot, the system freezes at the OSMC logo.

Usings a fresh install of January 2016 image, installed with OSMC installer. Raspberry Pi B+ with IQaudIO DAC+.

EDIT: Somehow there was two dtoverlay entries in config.txt. When I removed the line dtoverlay=lirc-rpi it began working.

hi
i’m using es9023 dac on rpi2 with osmc
I’ve made settings like below :

sudo apt-get install alsa-utils

sudo nano /etc/modules

Adding the content below, store them by “Ctrt+X” and then withdrawl

snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_pcm5102a
snd_soc_hifiberry_dac

sync
sudo reboot

In Settings > System > Audio Output I can select** ALSA: Default(snd_rpi_gifiberry_dac Analog)** but at this moment system is hangs.

who can help me .thanks.

I assume your issue is not related to the thread topic (otherwise it would already be solved) so suggest you open a new thread

1 Like

Since Raspbian 4.4.14+ the following entry is necessary in /boot/config.txt:

dtoverlay=iqaudio-dacplus,auto_mute_amp

To remove the standard Raspberry PI audio card, add

dtparam=audio=off

The last reply to this post is over eight months old

OSMC still uses the wrong statement

dtoverlay=iqaudio-dacplus-overlay

which does NOT work with the IQAudio devices. The IQAudio Pi-DigiAmp+ does not work out of the box with OSMC.

Please, use

dtoverlay=iqaudio-dacplus,auto_mute_amp

instead. Fiddeling around with GPIO 22 isn’t necessary anymore since Raspbian 4.4.14+

Will adjust, thanks.

Just to clarify: did you configure via My OSMC’S Pi Config? Which version are you using?

We will adjust DT to be more conforming with upstream soon, which will make -overlay necessary

Sam

I used the OSMC-installer today. If I remind well the newest version was 2016-09-xx.

I also did some additional tests. You can use

dtoverlay=iqaudio-dacplus

or

dtoverlay=iqaudio-dacplus-overlay

but you have to append

,auto_mute_amp

to unmute the power-amplifier circuit.

I’ll ask Gordon at iqAudio about this. It seems strange the board would need the additional parameter just to work out of the box. If this is the case, it’s certainly something that can be improved

The IQAudio power amps are muted by default in hardware. Until Raspbian 4.4.14 it was necessary to unmute the power-amp with a shell command. Since Raspbian 4.4.14 it is possible to use the device-tree statement. Have a look at section 12 of the IQAudio User Guide.

Thanks for this.

I am actually working with Gordon on producing images that work with the DAC out of the box.

I thought ALSA had to be used to unmute the mixer. I was exploring a kernel patch to address this. Being able to do this via device tree is handy. Thanks for bringing this to my attention.

Sam

I know that this is an old (one year) thread, but with the january update (2018) I suddenly have no sound from my IQaudio DigiAMP+. Everything looks correct, but suddenly I have no sound what so ever.

Any others with similar issue, and more importantly anybody with suggestions to how I can debug this.

If nothing else I will try another fresh image on it and see if there is sound then (or even worse it is hardware failure…)

edit: moved to [SOLVED] IQaudio no sound after january 2018 update

Can you please start a new post with some logs?

Sam

1 Like