June update errors out when installing "unknown package"

Dear OSMC team,

I just tried to update my RaspPi 1 with OSMC / May update to the June update, however I get this on the blue installation screen:

"An error occurred while installing the following package
(unknown package)

Please report this problem on the OSMC forum, making sure to include debug logs. Attempting to restart Kodi in 30 seconds."

I have seen that others are getting this problem sporadically, too, so maybe there is also a solution for my installation. Otherwise I won’t mind just doing a clean reinstall.

Here is what I did:

  1. My OSMC → enable debug logs
  2. My OSMC → manual search for updates
  3. update available, do you want to install → Yes
  4. error installing unknown package
  5. reboot after 30 seconds
  6. My OSMC → Upload logs

The logs are available at http://paste.osmc.io/rufunidacu - I hope they are conclusive. I could of course also activate logs, reboot, and then scan for updates, if that gives better results.

Thank you in advance for any help, and keep the good work up!

Log started: 2016-06-19 18:19:08
files list file for package ‘rbp-bootloader-osmc’ is missing final newline
Log ended: 2016-06-19 18:19:09

You might have a filesystem corruption.
I suggest you reboot and then run these commands via ssh

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get update
sudo apt-get dist-upgrade

If it works afterwards fine. If not I suggest to do a backup and a reinstall

thank you for the advice! I ran the four commands. apt-get update did not update any package, so looks like I was quite up to date. For the record, apt-get dist-upgrade did this:

The following packages were automatically installed and are no longer required:
libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal
libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal
libkrb5-26-heimdal libroken18-heimdal libwind0-heimdal
rbp1-image-4.4.6-3-osmc rbp1-image-4.4.8-3-osmc
Use ‘apt-get autoremove’ to remove them.
The following NEW packages will be installed:
The following packages will be upgraded:
armv6l-eventlircd-osmc armv6l-remote-osmc base-files-osmc diskmount-osmc
dmsetup dpkg initramfs-tools libdevmapper-event1.02.1 libdevmapper1.02.1
libexpat1 libidn11 liblvm2app2.2 libsmbclient libssl1.0.0 libtasn1-6
libwbclient0 libxml2 libxslt1.1 mediacenter-addon-osmc openssl perftune-osmc
perl-base rbp-bootloader-osmc rbp-userland-osmc rbp1-kernel-osmc
rbp1-mediacenter-osmc samba-common samba-libs tzdata wireless-firmware-osmc
30 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 88.9 MB of archives.
After this operation, 63.0 MB of additional disk space will be used.[/quote]

When I started the upgrade, however, I got the same error message as you found in the log:

[quote]Preconfiguring packages …
dpkg: unrecoverable fatal error, aborting:
files list file for package ‘rbp-bootloader-osmc’ is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)[/quote]

So it really may be the SD card. I’ll backup OSMC in the next few days and just do a reinstall. Thank you for the help!