Just updated to 5/2 and get sad face when trying to play movie

That basically reset device. No more settings, media, etc. Do I have to start over now or is there a way to revert?

You can revert.

This is a test to see if the Kodi code is failing or if there is something in your configuration that is causing the problem.

To revert:

systemctl stop mediacenter
cd
mv .kodi kodi-new
mv kodi-backup .kodi
systemctl start mediacenter

But first, I’d suggest that you add some data sources and see if it’s still stable.

Ok. Added source and played a couple movies fine. Reverted back. Played one movie fine then failed for next couple tries. What do you suggest now? Thank you for assistance.

Tried changing to default skin. Still failed.

It seems that it’s something in your configuration, possibly a setting, or combination of settings, that Kodi doesn’t like, or possibly a data corruption.

You now know how to move between your new and old configuration, so I’d suggest that you return to the new (clean) configuration and first add all your sources. Then, step by step, add the rest of the changes you want to make – and remember to test each time you make a change.

Matrix builds are in a separate repo so you would’ve had to add these too.

Hey everybody,

just a quick heads up - I had another sad face yesterday after quickly zapping through some TV channels. The movies and shows I tried afterwards played without hiccups.

I’ll try to produce another log file in case I see the dreaded blue fella again.

cheers
Anthrax

Update again – doesn’t look like you picked up any packages.

This pertains to what is happening to the hissingshark hyperion.ng I have installed.

Video plays fine from any source, the second I start hyperion.ng I get the sad face and a reboot. Video will not play with hyperion.ng running now. It was working so well for me lately until today’s update.

That sounds a little bit different to the issues reported here.

Could you send me a log when this happens?

Thanks

Sam

Not working for me again - definitely to do with hyperion/hyperion.ng on my side :frowning:

and this was working so well since christmas.

I’ll provide logs and might rebuild from scratch.

cheers
Anthrax

@nbraunstein
You reported this in another thread this morning. Am I right in saying it was resolved following update to the new version?

1 Like

Hi, I don’t know if you’ve seen yet but I’ve replied to your query on the Hyperion Github. Just to avoid an unresolved issue floating on the forum I shall paraphrase here:

The June update brings in the underlying changes needed to fix the a/v sync issue with Hyperion.ng, so then you just need to update Hyperion.ng from my installer to get the other half of the fix. I couldn’t update Hyperion.ng in my installer before hand, because without the kernel updates to go with it that breaks AML grabbing altogether!

Update instructions here! I hope that works for you as it has for others on these threads.

2 Likes

Hi @hissingshark,

thanx for letting me know - I knew you guys were on it :wink:

Holy hissingsharknado!
Anthrax

1 Like

Correct. Has been resolved.

I’m curious if I could skip the installer and go straight from GitHub?

I’ve done the recent update and one particular file gives me a sad face. After about the 6th time of trying it worked. Then I stopped it and the same thing happened again but worked after the 4th time. Weird. Doesn’t do it on other files. I’ve tested it on the VLC media player on the PC and it’s ok. 4K MKV. Odd.

Does this occur with a small sample of the file / a remux?

I reinstalled everything today including hyperion.ng with the needed argument after the installer. Seems to be working fine so far. Haven’t experienced many A/V sync issues either. Noticed the network takes much longer to connect after reboots or sending a reboot command via SSH sometimes takes upwards of 30 seconds. I think it’s all Hyperion.ng related.

As I have just responded in the regular Hyperion thread, no arguments are needed. That I think is why you are still using the old version, hence the A/V sync issues.

Anyone updating can just follow the update instructions. It’s all there - easy as :pie:.

Oh I’ve done a few fresh installs since than. My A/V sync issues are most likely related to PlexKodiConnect.

Hyperion.ng will not start using the feature in the script app by the way. It works for turning the lights off when the screensaver is enabled though. Just make sure it’s on Platform Capture rather than Hyperion.