Kernel panic direct after installation

I still using RaspBMC, but I thought that I try OSMC but I can’t get it to work.

After writing the image to an SDcard and startup my Raspberry Pi 1 it shows:

  1. Formating device
  2. Installing files
  3. OSMS installed successfully
  4. (reboots)
  5. Kernel panic - not syncing: No working int found.

I tried creating new SDcard multiple times, but the same result.

(I’m happy that I kept my SDcard with RaspBMC.)

Not much info to go on there…

Which model of Pi 1 is it ? A, B, B+ ? 256MB or 512MB ?

What size SD card and have you tried a different one ?

I assume you chose an SD install not USB ?

Oh…, I’m sorry.

It’s an Raspberry Pi 1 Model B with 512 MB RAM, and an 8 MB SDcard.
(currently I don’t have another SDcard to try with)

Yes, I selected SD install, not USB.

Displayed on screen:

I really hope you mean 8GB not 8MB ??

If it can’t find init it means there is a problem with the file system or some of the system files were never copied during installation. My money is on a problem with the SD card.

Yes, of course it should have been 8GB.

I have now found an 4GB SDcard, and it seems to work with that one.

So it was most likely a bad SD-card.