Kodi 16.1 Update library problem "Skipping item with .nomedia file"

Hello. I have osmc (kodi 16.1) on raspberry pi3. Works fine except for video library updating.
I use network source with protocol webdavs. I don’t use external sql. Video files are in separate folders. Folders names are as on imdb.com and often when updating - update is not correctly going on and I have
logs:
WARNING: Skipping item ‘davs://USERNAME:PASSWORD@webdav.:443/movies/’ with ‘.nomedia’ file in parent directory, it won’t be added to the library.
WARNING: Skipping item ‘davs://USERNAME:PASSWORD@webdav.:443/movies/Who%20Framed%20Roger%20Rabbit%20(1988)/’ with ‘.nomedia’ file in parent directory, it won’t be added to the library.

Network cloud server doesn’t have ‘.nomedia’ files in that folders.

I tried:
advancedsettings.xml
< advancedsettings >
< video >
< excludefromscan >
< regexp>[!-._ \/].nomedia[-._ \/]
< /excludefromscan >
< /video >
< videolibrary >
< usefasthash > false < / usefasthash >
< / videolibrary >
< /advancedsettings >
but without success. All the same.

If I update exact folder - it is updated with success.

So I have questions:

  1. Does anybody know what wrong is with my updating process? Is there workaround ?
  2. Is there better network protocol for network streaming of kodi then webdav like ftp or scp for ex. ?

I am a bit confused here. It seems you on purpose have set the nomedia to avoid scanning of the folder and then you say it is not working?

Also this sounds very kodi specific so you might find better help at http://forum.kodi.tv/index.php

I did’t try to avoid something and there’s actually no such file in that folder but kodi thinks there is - that’s the matter!

And I tried to mount webdav resource and to search .nomedia but without success:
mount -t davfs https://webdav. /mnt/webdav/
find /mnt/webdav -iname ‘nomedia

I don’t understand why kodi thinks there’s .nomedia in “movies” folder when actually there’s no such file in that directory.
Any ideas ?

You know that it is a hidden file?
Did you enable to show hidden files when you checked that folder?

I mounted webdav resource and checked with ls -la and find linux tools. This tools show hidden files either. There’s no such file.

Your find command is incorrect. Try

find /mnt/webdav -iname '.nomedia'

Doesn’t the warning message say the .nomedia file is in a parent directory?

Did you resolve this issue? I am having the same problem. Look like it has to do with FTP. No such file and the FTP logs show

media (IPaddr)> MDTM Servers/filelocation/file_name.avi/.nomedia

also searched in SQL and can’t find anything with “.nomedia” in it

Well not 100% sure what are you trying to say. Do you have .nomedia in any of your directories (check top to bottom) and remember that a file starting with . would be a hidden file?

Surely the .nomedia file would not be recorded in the SQL database

“Well not 100% sure what are you trying to say. Do you have .nomedia in any of your directories (check top to bottom) and remember that a file starting with . would be a hidden file?”

Correct. no such file.

“Surely the .nomedia file would not be recorded in the SQL database”

I would think not also. but wanted to rule it out.

The library stopped adding new things about a week ago. Figured it was the scrappers. But to test I took kodi on the PC and cleared sources and started fresh. Added on folder and it scanned it but only show the networks of the shows. So I cleared it again and did it w/o SQL and no ftp (all media is on the pc). They all scanned fine. Searched SQL found nothing stopping it from scanning. Cleared Kodi again and added just the folders (no ftp) and test DB in SQL. Worked fine. Cleared it again and added sql and FTP. Back to the problem. Searched the FTP log and thats what it said

media (IPaddr)> MDTM Servers/filelocation/file_name.avi/.nomedia

Well that would indicate that you FTP server contains a .nomedia file.
Anyhow if you want to find whats going on enable debug logging and start the scan into library and then upload the logs files

https://paste.ubuntu.com/25907616/

This log file is not from OSMC so not sure what is the relation here? Anyhow the log clearly states “with ‘.nomedia’ file in parent directory, it won’t be added to the library.” so remove all your .nomedia files from your server and the items wiill be scanned correctly. Reminder:

  1. .nomedia is a hidden file so you only will see it if you enable to via hidden files
  2. The .nomedia can be in any directory that the video comes from (eg Servers or server1 or Dylan or Tv Shows or 13 Ghosts of Scooby-Doo, The or Season 01

sorry osmc is on my pi also, but am having the same issue on all builds. But testing on pc since I have access to folders from the drives and can rule out remote issues. He had posted this in many places but this happened to be the last place I can see the op was recent in. So figured this was the best bet to see if he resolved it. Also I know it clearly shows it but like op said. It’s not there. When I add the same thing via foldes and not ftp it scans fine. My hidden setting is on and I can see all files.

Then I think you better take this to the Kodi forum
https://forum.kodi.tv/

Newtester already did. Update library problem "Skipping item with .nomedia file"

Sorry for posting here. Like I said was trying to see if there was a solution that he found. Thanks for the help.

I just changed protocol from webdav to http and moved to my own server from “ready cloud” and that hepled me.

Update - It’s KODI. I downgraded, changed nothing of my FTP settings, and it worked fine.