Kodi 17.2 & 17.3 Problems Playing/Ripping CD

It all seemed to work before Kodi 17.2, I managed to Rip my entire CD collection to a USB stick and I was happy. Decided to buy a 32Gb SD card to transfer Kodi and the USB files to and also bought two new CDs.

I imaged the SD using the June’17 image sourced via "raspberrpi.org/downloads link. I noticed a few features were now working (thanks guys) but Ripping CD was one that wasn’t working now.

I’m using and external LG DVD drive. Kodi 17.3 will happily load/play Region 1 DVDs without issue (I’m Region 2). Inserting a CD gets the drive light flickering but little else. No play and no rip. I fiddled with the settings rebooted a couple of times but nothing. It looks like the DVD/CD drive isn’t getting mounted correctly under Kodi 17.3 as I don’t see “Disc” appear on the left menu.

Went back to the previous SD with Kodi 17.2 and was able to rip one CD and then (I think) it upgraded to 17.3 and wouldn’t rip my second CD. I guess it’s now a bit cranky.

I have searched here for similar problem but would need to ask the correct question. Also assume folk don’t buy and rip their CD collection any more, I am over 65. Maybe I just arrived at Kodi at a bad time.

Thank you.

DVD and CD issues won’t necessarily be related

Not all DVDs can be decrypted trivially
Music ripping should work fine

Make sure the drive has enough power

Guys, [Sam],
Yep! The Pi is known for problems where it can struggle to supply enough power from its USB sockets. In my case the DVD(CD) drive is powered externally and shouldn’t present any significant power drain on the Pi.

I went back to the Feb 2017 release and apart from being able to RIP a single (the first) track from two different CDs it was the same problem. Playing these RIPped tracks seemed OK except they both ended abruptly with a clunk. Was using the AAC codec.

I went back to the Dec 2016 and Kodi 16.1 release. A whole lot different in every way. Using (more or less) the same settings: AAC codec @192 bit rate I had similar problems to using Kodi 17.1.

Changing the codec to WMA and same bit rate it and all worked as advertised and I was able to encode my two new CDs. I have yet to listen to them or add them to my collection because that’ll be on my Kodi 17.3 SD card, another little challenge later.

So, returning to the Kodi 17.3 SD image (and this is only replacing the SD card from a 16.1 to a 17.3 bootable image and powering back on) I find the RIP and PLAY CD on loading doesn’t work for me. Certainly “DISC” does not appear as with 16.1. For reference the 17.3 is as far as I can tell an out-of-the-box configuration except for me defining a saved music location (/home/osmc/Music), setting “Audio CD insert action” and defining the Codec to AAC and WMA.

Would (humbly) suggest the current start-up Wizard be extended to include options of “Where do you want your music?”, “What Codec?” and “What about CDs (remember them)?” so numpties like me get it right from cold.

So, it would appear that (My) Kodi 17.X doesn’t work for me for either RIPping or PLAYING CDs with either WMA or AAC codecs although, as previously, it’ll load and play DVDs (at least one US one). On loading a CD the drive wers and clunks a bit, the drive activity light flickers but nothing else happens.

On the same hardware Kodi 16.1 works providing I specify the WMA codec. The Kodi 16.1 AAC codec would appear to be a bit cranky. Maybe both Kodi 17.X encoders are cranky.

I recall a while having similar problems with the AAC codec being a bit choosy about what it would encode.

Again, thank you for your attention. Hope this feedback will help. I guess someone will ask for logs. Might need a bit of hand hold for that.

This is a Kodi issue, so would be best raised there.

Will investigate, but may not be necessarily Kodi related. It could be the kernel. Some full logs might give us clues as to whether there’s a hardware issue.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.



Guys, [Sam],
Been at this all day with mixed results so it will have to be a rain cheque on the logs, I’m exhausted.

I tried the Kodi 16.1 again with another CD and got the same problems as with Kodi 17.3.

I then installed the Windows (on Win7) version of Kodi 17.3 in an attempt to get a quick result on encoding my CDs. Set to the WMA@192 codec all worked as advertised and I was able to complete the two CDs in the jewel case.

Out of interest I selected the Win-Kodi 17.3’s codec to AAC@192 and attempted a second pass on the CDs. As with the Raspberry Pi system it barfed after coding the first track on each CD so a very definite NO GO with the AAC codec.

So, two fresh installs of Kodi 17.3,the same minimal configuration from default on two very different systems and I get very similar failures. The only really common thing is me.

Will attempt producing a set of log files when I surface again and get my head around what I need to do. Feel free to chip in on this one.

Again, thank you for your attention and I hope this feedback to helping in some small way.

Need those logs to have any idea what’s really going on.


Guys, [Sam]
The following log file comprises:
Raspberry Pi 3B, 2.5Amp PSU, Wireless Mouse dongle, 32Gbyte SD, External (supply powered) LG Super Multi DVD Writer.

Have preset the Audio Encoder WMA, and CD RIP, enabled debugging and rebooted.

log file: Log file covering insert 2 CD and 1 DVD. No response to CD.. The action on inserting a DVD was to bring up the “and do what with menu”.

Apart from the drive light flickering and noises of the CD spinning up there was no response on screen.

Second log file As per above but using AAC encoder, reboot, (open DVD drawer put in CD and close) x 2.. No response to CD being inserted.

Apologies for the delay replying. Hope this helps.

(Edit to correct ".5 to 2.5Amp PSU)


Miss posted here. Posted to Kodi forum. Sorry.

Thank you “bmillham”

@RaspiSteve, a problem with Windows 7 is not OSMC related, you should contact the Kodi developers.

1 Like

Thanks for the help and pointers…

Have opened a thread on Kodi forums here: https://forum.kodi.tv/showthread.php?tid=317254&pid=2608800#pid2608800

Will try to get better at this soonest.

Got it, Sorry.

Have posted this on the Kodi forum. Turns out its not a Windows but a “Music” related thing. Confused? I am.

I think they just mean that you posted on the wrong forum on Kodi, so just wait for a response there.

May just be a coincidence but as of a few minutes ago when I checked and installed the updates (26 June’17) my Kodi 17.3 is spotting a CD getting inserted and bringing up the Disc and the Play/Eject menu in a similar way on inserting a DVD. Brilliant!

Not sure the audio quality is entirely brilliant, sounds like there are drop-outs but a massive improvement.

Ripping still doesn’t work.

So, Thank you very much. (can I add half a tick?)

After a bit more research spotted a recommendation for the FLAC encoder, found it, installed it and another result.

I can now RIP CDs if I install and select the FLAC encoder on my Pi 3B Kodi 17.3. Have only tried one CD which although a bought one doesn’t feature in the detail database but I can play the files

Think that warrants a tick. This sort-of points the WMA and AAC encoders being a bit broken.

Guys, Update 27 June.
Well it did all work after what looked like a patch and then there was another bigger update and now it doesn’t. Been going around in circles but think its down to OSMC/Kodi 17.3 not recognising audio CD insertion. It sees and reacts to both data CDs and movie DVDs and the menu item “Disc” appears. Nothing happens on screen on inserting an audio CD.

May be I’m the only one left with a DVD/CD player using Kodi. Hope the logs I’ve posted above can show what’s happening.

There haven’t been changes to Kodi in any recent updates. Something else is definitely the issue here

Guys, [Sam],
Just incremented back to the March 22 release of OSMC/Kodi 17.1 and have been able to rip some CDs using the WMA encoder.

However, not a complete success. Of a 3 CD set the first breezed through without issue, the second barfed at track 7 but a restart got it completed. The third CD didn’t/wouldn’t rip instead the [Play disc]/[Elect/Load] pops up. and playing it seems OK.

I also noticed while ripping that a little thermometer kept popping up just below the the progress circle. Nice feature, guess its getting hot in there.

I found a site reporting Kodi 16.1’s final fix release was late April 2017 and was hoping to get the last Kodi 16.1 to try. The SD image for April turned to be the May release. Hey Ho! I’ve worked back from there.

I’d be more interested in resolving the issue, and to do that, would need to see some logs. It’s not really ideal for you to use an old version of OSMC forever, particularly as there have been a few security vulnerabilities in Linux, the Debian userland and Kodi over the past year


But there’s a problem…

Actually I’m off at the crack of dawn paddling down a river so off line till Saturday then Sunday away for two weeks.

Been working back to the January '17 image of OSMC/Kodi 16.1 and that doesn’t rip or play CDs. The February image turned out to be an early 17.1 and that didn’t react to an audio CD insertion either.

Unless advised otherwise will generate logs for the March 22 release of OSCM/Kodi 17.1 which sort-of worked. Please make a point of particular log features/option that will help you. I will need to go image another SD.

Edit: just looked at one of the logs referenced further up and it includes a number of error reports e.g.

osmcpi3b udisks-glue[361]: Trying to automount /dev/mmcblk0p1…
osmcpi3b udisks-glue[361]: Failed to automount /dev/mmcblk0p1: Error mounting: mount exited with exit code 1: helper failed with:
osmcpi3b udisks-glue[361]: mount: only root can mount /dev/mmcblk0p1 on /boot