Kodi does not read local scrapped info

I am new to OSMC and my first impression on my Raspberry Pi 2B is more than excellent. However I have few issues hoping that someone can help me with.

I am planning to add dedicated drive through USB directly to my Pi, but in the meantime I added different sources where my media resides on my network. I read some stuff here and other places and realized that NFS share is preferred to others. I have two NAS drives with media and added them as NFS shares. I can see contents, but Kodi does not want to take metadata arranged properly with correct .nfo file within the folders for individual TV series ( I created them with MediaElch). I disabled Thetvdb scrapper and instructed to use local info but Kodi does not budge. So i had to scrape again.

I wonder where all scraped data is kept? If it is on raspberry I am afraid that it will very soon be full because I have a lots of media I want to add. Is there a way to keep all these files somewhere else on the network? Also what is the name of the file and folder of main database on Raspberry? I just want to check how big it is using Filezilla?




You can use a MySQL database or re-map (with symlink) or changing KODI_HOME variable. MySQL database is probably best if you are going to add more systems in the future and want a shared library


Even with “local info” selected Kodi has to scrape the folder in order to read the local info, it does not just automatically see it. The info is stored in the MyVideos**.db once it is read from the .nfo files Artwork is cached in the userdata/Thumbnails directory and indexed in the Textures**.db

WOW! Amazing! 16 minutes and I got 4 replies. That is helpful community. Thank you guys. I feel I will use this a lot (till I become an expert and help others).

My database is already 11MB and I did not add a fraction of my current movie and TV files. Is there a limit in terms of size for optimal performance?

Also, ome of the episodes are not listed but they have proper .nfo data. I tried few times to re-scan but they are still not showing? Any idea what can cause that?