Kodi Krypton Live TV hangs

I upgraded to the new OSMC Kodi Krypton release yesterday. I needed to reinstall the DVBLink add-on for watching Live TV. As the new skins aren’t to our taste we also got Confluence back.
The Live TV buffering problems we had with previous releases on RPi seem to be over. This problem seems to be replaced with another one; a few times already, in just over a day, when starting DVBLink LiveTV when the system has been idle for some time by selecting a channel system does try to start stream and has the busy circle active. Nothing else changes. TV / CEC remote is then blocked, but Kodi remote app on iPad has some response. So I can reach home screen, but nothing more. Also reboot through app does not work. All left to do is pull the power plug. After restart Live TV is possible again.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OK, I had to wait for the error. Seems that when system has been idle for a while (>6 hours, just now) LiveTV doesn’t start the selected channel. It keeps running “busy”. Now I managed to restart through Kodi Remote app. This morning when I tried Live TV worked, but got a system fail (sad face).

The logs are at http://paste.osmc.io/afavogucig

11:31:01.980 T:1727001584   ERROR: SQL: [Epg11.db] The database disk image is malformed

That will cause problems. I’d suggest you move it out of the way. e.g.

mv ~/.kodi/userdata/Database/Epg11.db ~/.kodi/userdata/Database/Epg11.backup

and restart kodi. It should create a new one.

Thanks. Yesterday, I did what you suggested and rebooted. Today, early evening my wife wanted to watch TV and set channel after system had been idle for over 6 hours, and same problem occured. Had to do reboot through Kodi Remote app.

Anything else from the logs I posted?

Remove the overclock (core_freq=450) and see if problem still occurs.
If it does post a new debug log.

I’m not aware that I ever did an overclock. What I did though, was replace this TV’s RPi2 with an RPi3 and just exchanged the SD card. I did this some weeks ago. Today I saw the same problem occur on one of the other OSMC TV RPi2 I have in the house. This one wasn’t updated yet, so still runs the January version. I believe they both have different DVBLink Add-on version.

The core_freq=450 is present and is an overclock (default is 250 on Pi2 and 400 on Pi3).
Remove the core_freq setting from config.txt or use the MyOSMC add-on.

Update: I contacted DVBlogic support and they’ve been looking into this. They were very nice to give me an update. They said they found a bug in Kodi that is responsible for DVBLink PVR client error in Krypton. They seem to be having a hard time convincing Kodi Support Team, who say it is in the PVR. DVBlogic is currently working on a workaround. In my case I had to go back to previous release of OSMC, since all the family relies on OSMC for watching TV and KODI/OSMC Krypton just didn’t work for them. WAF was becoming subzero…

DVBlogic has fixed the problems by releasing a new add-on, version 3.4.0
It has been added to Kodi nightly releases. When will it be available in OSMC? I had to revert back to Kodi 16, because of this. Would like to be able to start using Krypton throughout the house.