KODI low screen res on "DESKTOP" setting, but OK on 1920x1080p


Firstly I want to thank You for nice peace of software for my RaspbPi2 B1.
OSMC is working with my 55pfl8109 TV and Philips Fidelio B5 soundbar if it’s important info.
TV picture mode is set to “Original” so it’s not stretching anything - it’s 1:1.

One thing bothering me (well … maybe two).

When I set Settings->System->Display mode to “DESKTOP” then GUI is becoming really tiny (I think that’s 640x480), but if i “force set” it to 1920x1080p everything seems to be OK. Weird thing is, that “DESKTOP” was working fine for 1/2 restarts after install, and then after exiting a 3D movie Half-SBS it has changed to tiny one and now it’s always like this when I’m trying to pick “DESKTOP” instead of 1920x1080p.

Second is connected with 3D mentioned above. After watching a movie, 3D mode should be changed to 2D (I has this setting checked in Kodi Video Settings) … sometimes it’s working fine, but in most of cases it will exit to KODI UI, but the UI will be in wrong proportions, sometimes still acting like 3D (double image), and sometimes changing to different source and then again to RaspbPi is fixxing this ISSUE, but sometimes only OSMC restart helps…

Does someone know what’s going on? Maybe I should provide You some logs (from where to grab them?)

“DESKTOP” resolution is whatever resolution the Pi boots in (before Kodi loads) which in turn is controlled by your TV reporting its preferred resolution over HDMI using EDID. (Unless you override this in config.txt)

Try putting it back to “Desktop”, reboot, and if the resolution still looks wrong post the output of the following commands:

tvservice -s
tvservice -m CEA
tvservice -m DMT