KODI problems with Hifi Berry.No sound!

I have successfully connected my RPI+HifiBerryDAC with Kodi,to my old hifi stereo system,but there is no sound,no music!
To configure (in My OSMC / hardware support … and setting / system / audio output …)
I followed this link:
I tried VOLUMIO and everything is ok! No problem.
Where is the problem with kodi?! Where is the error?
thank you

There should be no problems if you follow those directions correctly. We have hundreds of users with HifiBerry.

The guide of HIFIBerry is easy.I believe i have followed good…
Are two simple steps.Or not…? :blush:
Repeat, by Volumio the Rasp + hifi berry works! So it’s a configuration issue of kodi. (I tried two versions of Kodi on two different SD and does not play!)
help :slight_smile:

PS excuse my bad English but I write from Italy


You are right, since March’s update passthrough sound is missing. My device is HifiBerry digi plus.

It is a funny problem ;). UI interface sound remains normal when moving throught the menus, and it is adressed to AVR correctly via SPDIF output of my HifiBerry, but just when you command any playback, sound goes to directly throught HDMI to TV (in my case) instead of to AVR. And it is set to be sent throught HifiBerry.

No-changes were made to previous settings of my hifiberry digi before updating, neither later. So problem comes forn last update 4.4.27-9.

I’ve re-checked whole stettings concerning HifiBErry and all are correct, and I physically tested the board as well, and not problems where found.

What happens is I don’t know how proceed form here on, but awit till a nuw update is deliveres fixing this problem.

Any suggestion will be very welcome.


Did you change the settings level to advanced or expert (bottom left of the settings menu)? Nothing is broken here and no need for a new update.

For passthrough to work with HifiBerry Digi you need an alsa config file. This isn’t currently included with OSMC.

If you grab this file:

and put it in /usr/share/alsa/cards I think it will fix the issue.

Hi again,

Thanks for your support.

Problem is mostly solved.

HifiBerry is well configured and working as I said. But I found a conflict on this board when I select the OMX and/or MMAL hardware acceleration on . This causes passing sound througout SPDIF to AVR stops, and inmmediately is redirected to HDMI output.

So, deselecting those hardware accellerations, everything gets back right.

But another problem arise. Doing so, when any online stream is selected from library, its playback become fully tugged. Only from online. Never from USB.

But there is a workaround. Sendding previously this online stream link to fauvorites, brings back a seamless playback.

I think this is because some kind of conflict with anyother addon, but still under research.


OMXPlayer does not support alsa. It can only support the analogue and hdmi outputs.

MMAL acceleration shouldn’t cause any problems.
The default setting (on PI2/Pi3) is for OMXPlayer to be disabled and MMAL enabled.
That should support alsa (and so hifiberry) just fine.

Even if you have OMXPlayer and MMAL defined it will fall back to MMAL when the audio output device is alsa.

The behaviour you have described should only occur when OMXPlayer is enabled and MMAL is disabled.

I will get this included in a future update