Kodi unable to connect to the server on my Raspberry

Hello all,

I already try to re install Kodi or reinstall the scrapper without success.
When i update my database with IMDB scrapper for TV Shows this works fine
When i try to update my database with The Movie Database for the film i have always the same message “unable to connect”

I joined the log in debug mode.

Please help me this problem appeared for 4 month and i tried a lot of things to solve this without success.

Additional information : I installed kodi on my MAC book and all it’s ok the update works. I am connected by WIFI and my raspberry is connected by cable. I don’t understand the difference
FIND

20:38:15 553860.937500 T:2820404208 DEBUG: VideoInfoScanner: No NFO file found. Using title search for ‘/media/Stock_Mara/Films/Elysium.mp4’
20:38:15 553860.937500 T:2820404208 DEBUG: FindMovie: Searching for ‘Elysium’ using The Movie Database scraper (path: ‘/usr/share/kodi/addons/metadata.themoviedb.org’, content: ‘movies’, version: ‘3.9.0’)
20:38:15 553861.125000 T:2820404208 DEBUG: scraper: CreateSearchUrl returned http://api.tmdb.org/3/search/movie?api_key=f7f51775877e0bb6703520952b3c7840&query=Elysium&year=&language=en
20:38:15 553861.125000 T:2820404208 DEBUG: CurlFile::Open(0x9ae1c108) http://api.tmdb.org/3/search/movie?api_key=f7f51775877e0bb6703520952b3c7840&query=Elysium&year=&language=en
20:38:25 553871.187500 T:2820404208 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
20:38:25 553871.187500 T:2820404208 ERROR: CCurlFile::Open failed with code 0 for http://api.tmdb.org/3/search/movie?api_key=f7f51775877e0bb6703520952b3c7840&query=Elysium&year=&language=en
20:38:25 553871.187500 T:2820404208 ERROR: Run: Unable to parse web site

It would seem like you have a network connectivity issue.

Can you ping it? (ping -c5 api.tmdb.org)

So we can see your kernel messages etc, could you please post a full set of logs? Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Thanks for your fast reply. Here the result of the command

ping -c5 api.tmdb.org
PING api.tmdb.org (104.20.6.159): 56 data bytes
64 bytes from 104.20.6.159: seq=0 ttl=52 time=84.895 ms
64 bytes from 104.20.6.159: seq=1 ttl=52 time=81.808 ms
64 bytes from 104.20.6.159: seq=2 ttl=52 time=84.301 ms
64 bytes from 104.20.6.159: seq=3 ttl=52 time=80.152 ms
64 bytes from 104.20.6.159: seq=4 ttl=52 time=81.341 ms

api.tmdb.org ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 80.152/82.499/84.895 ms

So that proves you now have connectivity, can you retry scraping the movie again?

I retried and i had the same error :frowning:

We’ll need more detail to get any further.

Ok i will try to find another logs, but i don’t know where i can find a log usefull for you.
I don’t understand why all works with TV Shows but not with Film or extension !!
Did you have a way to solve my problem ?
Thanks

We’ve provided you with a link that contains explicit instructions twice.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

We need you to

  1. Turn on debugging in kodi.
  2. Reboot RPi.
  3. Recreate problem.
  4. Go to MyOSMC and upload logs.
  5. Type URL for logs back here.

Please tell us which of these 5 simple instructions you can’t do. Without you doing these (just these!) we cannot help you further.