Kworld ATSC tuner not recognized


My previous setup was with osmc on a raspberry pi 3 and my live tv was working fine using tvheadend server from osmc store.

Now I just upgraded my box to a vero 4k and so far it works great, except it doesnt seem to recognize my atsc tuner.

I plugged the Kworld tuner into a usb port like I used to do on my rpi3, but in the tvheadend server setup, it doesnt see any tuner in the config.

Anyone has any experience configuring a tuner like that on the vero 4k? Do I need to install some kind of driver or library so it can recognize my tuner?


What kind of tuner is it? DVB-T/S/C?

here it is:

Please paste output of lsusb (install usb-utils first) with it attached



Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 1b80:e34c Afatech
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

OK – support may come in next update


ok thanks, any ETA or is there anything I can do to enable it manually in the meantime?

It was working with under rpi3, so I assume it’s not missing much

OSMC on RPi3 is using a 4.9 version of the Kernel while the Vero4k uses a 3.14 version. So @sam_nazarko manually need to backport drivers for TV Dongles for the 3.14 Kernel. So unless you want to compile that by yourself you will need to wait for Sam to do his magic.
As he wrote he may be able to do so for the next update (which normally would be published towards the end of the months.

Some magic is about to happen. It would seem.
All we’ll need is your feedback


ok cool, keep me posted and I’ll gladly test and report !

1 Like


I just saw the new update was available, but from what I can tell, there is still no support for my TV stick. Was this supposed to be included or is it still due in an upcoming update?


Hi — I can send you a test build if you’d like to try this



I would appreciate it if you have one.