Lack of contrast compared to Kodi on Rasp 3b

Hello there. I’m new here so forgive me if I’m “out of line”. I recently purchased a Rasp 3 in order to watch mkv. H264 works just perfect with Kodi. Wanting more, I just purchased a VERO 4K. H265 read fine although it does have a bit of clipping (slight) from time to time. But my real issue is this one : After comparing the two, it appears that when reading the same mkv H264 file on Rasp 3 and on VERO 4k, I get a lower quality with VERO 4K. The contrast is naturally better on Rasp 3 running previous version of Kodi. On Vero 4k I get lower contrast with default settings and some kind of trail in the image. Has anyone else experienced that ? Maybe I should go through settings ? Thanks for any input I might get.

Hi,

this very sounds like an issue with a wrong color space in use; unfortunately I do not have a Pi3 (Pi2 instead) and no Vero 4k (Vero1+2 instead). Nevertheless what would be helpful for the support people here to better understand your situation:

  1. Is it possible to make a camera screenshot from Pi3 and Vero 4K from same video scene demonstrating the difference?

  2. To understand that “good” setting with Pi3, ssh to the Raspberry and take the following outputs
    2.a) sudo tvservice -s
    2.b) sudo cat /boot/config.txt | grep -i hdmi_pix

  3. Try to find out with your TV what HDMI color space is set and can be configured: Watch out for configuration settings like HDMI RGB/yCbCr auto/full/normal/limited etc.

The picture quality can vary because they’re different pieces of hardware, but not significantly, and you will be able to adjust some settings like contrast.

What’s cat /sys/class/amhdmitx/amhdmitx0/disp_mode and cat /sys/class/amhdmitx/amhdmitx0/disp_cap show?

Cheers

Sam

Hello there, yes I am going to take the time to make te screenshots comparisons asap ! HDMI input was the same for Pi3 and for Vero 4k. I am using a old model of Sony Bravia. It’s not even a full HD Tv set. But I have to admitt that the colour display is really really good ! I’ll follow up as soon as possible. Thank you for you help.

Try:

echo 1 | sudo tee /sys/class/amhdmitx/amhdmitx0/output_rgb

Will do !