Lag in NFS since September 2015 update

After upgrading I am noticing much more lag in the NFS connection. I am streaming from the same source as before the update. The Video Is freezing but the audio is playing along, after a few seconds the movie very rapidly catches up with the audio.

This issue was not there before.

There have been no changes to NFS. There was a library bump but this was reverted

Please reboot and see if symptoms continue. If they do, we will need logs to find out the cause of the problem


I rebooted twice and even restarted router and NAS.
Will upload logs tomorrow.


That would be best

We haven’t changed NFS libraries or behaviour, so it is likely a local issue, but without logs we are just guessing


I’m having this issue as well. Please let me know if there is anything I can do to help trouble shoot this issue.

Please see above. Is this lag related to an in Kodi mount or an fstab based share? Can you provide any iperf output to show evidence of a regression?


Same problem here as well with the added bonus of a couple sad face crashes. Attempted to enable logging and send the logs but there was a crash during the log writing. Now I’m in a sad face reboot loop. Any help would be greatly appreciated.


You will need to upload a log for us to see why you’re getting the sad faces

I’m not trying to be funny: but without any logs whatsoever, it is anyone’s guess as to what the issue is, or if these issues are even related.


I hear you. I pulled the power and restarted and managed to get it back up and running. Attempting the process again to get logs for you, now.


Hmm… failed again. Any specific logs I should be sending? Perhaps limiting the size might help?


Please replicate the problem, with debugging enabled and upload a Kodi.log


Right. Managed to get a response from the log uploader without crashing but the message is ‘document exceeds maximum length.’ Selected only kodi.log and got the same response.


You will need to re-boot and try and produce a smaller log. Our server accepts logs of up to 10MB, so it would be good to try and get that down


Wow! Well… tenth time’s the charm?! Here’s the log, finally!

Thanks for your patience. Hope this helps shed some light.


Hi Duke

Thanks for getting back to me.

I can see a few timeouts when trying to connect to:

Some troubleshooting steps:

  • How are you connected, WiFi or Wired?
  • How is connected?
  • Can you ping reliably?
  • Are you having any connectivity issues to any other devices on the network or when streaming over the Internet?

We did have a (unrelated) issue where NFS did not work at all, but that was because the name of the shared object was incorrect (Kodi was not loading it), and this has since been resolved. NFS should be unchanged, but something’s clearly not quite right here.



Interessting… is actually my smartphone running Yatse. All the other devices are hard wired. Files are streaming from NAS at so… I’m not sure where that leaves us.


Are you using Yatse to control your system? Can you try using some other devices (such as a keyboard) for now?

I am a bit puzzled by all of this, but setting a static IP or a reservation is always a good idea for key infrastructure (printers, servers etc)


I normally use Yatse for control, yes but there is also a wireless Logitech K400 keyboard with USB dongle attached. I just shut down Yatse and the lags are still present. Yes, I’m using IP reservation on the router so all the addresses are essentially static.

I’m not sure if any of the following is related or helpful but… I had setup RaspBMC on my original Pi’s with NFS UDP settings some time ago and continued doing so when I switched to OSMC and Pi2 (and Vero) but strangely, at some point in the last couple of months, it no longer worked well with UDP settings so I switched to TCP which, until the September update I ran today, had been working well.


[Update] I just tried running the same files on my Vero and I’m not seeing the same lag issues so perhaps something went wrong during the update on the Pi2?

I’m also experiencing this since the Sept update… I have a Pi2 with the latest OSMC. Nas is mounted with NFS through fstab.

The lag/short video freeze seems to go away when I use OMXPlayer. I noticed in my case it’s strange that the video stutters/lags with dvdplayer but the audio seems to play without error.

Hmm. I feel like we’re collating a lot of +1 / “me toos” even though these issues do not seem related at all.

The other posters here reported that they had issues with Kodi based NFS mounts, not fstab ones. I don’t think the issue is related to NFS at all. Especially since:

This actually sounds like a playback regression. Can you copy a problematic file on to local storage (hard drive) and see if the problems go away? If they don’t then we can rule NFS out as a culprit