Lag on entering myOSMC

I run OSMC on both Pi B and Pi 2. On both devices (but maybe worse on the Pi B), I notice a significant lag between selection of “myOSMC” and opening of the menu. The lag can sometimes be up to 30 seconds. Is this expected?

The “extra” slowness on the Pi B makes me thing this is a hardware / processing time issue. But that seems strange because I would not expect entering myOSMC to be too intensive (that is, without knowing any of the under-the-hood details of what happens when I select myOSMC).

I run pretty bare-bones setups (I think Weather is the only add-on I use!), so I don’t think it would be anything there.

If it’s a clean install that seems to be slow I would suspect a slow SD card. What kind of SD card is it ?

A couple of seconds is typical opening time for My OSMC on a Pi 2.

Thanks for the feedback. I will check the SD card details tonight and report back.

I am curious, what happens when My OSMC is clicked? Since you mention slow SD card, does that imply that some significant amount of data gets read on click?

It’s not a big issue, but even a lag of a couple of seconds might give users impression of lag? (That is, considering that all other menus open immediately.)

@DBMandrake - as requested, the cards are as follows:

  1. (the Pi 2) SanDisk Ultra Plus - 16 GB - UHS Class 1 (10 MB/s)

  2. (the Pi B) SanDisk (basic black) - 16 GB - Class 4 (4 MB/s)

So I the card in the Pi B is clearly slower. But I am still curious / unclear why card speed is coming into play so strongly when My OSMC is clicked. Isn’t a 30s lag excessive, even with a slower card?